Running Ubuntu 12. 04. Installed both "VirtualBox" and "X86 virtualization solution - base binaries". I downloaded a newer version of Virtual Box, specifically "virtualbox-4.3_4.3.6-91406~Ubuntu~precise_i386.deb", from the downloads page.

When I try to install this by right clicking on the file, and selecting "Open with Ubuntu Software Center", the Software Center opens with the error:

Conflicts with the installed package virtualbox-guest-additions-iso

Having previously installed GDebi, I can also right click that same file and select "Open with GDebi package installer", and that process results in the exact same error message.

Since the package virtualbox-guest-additions-iso is a part of "X86 virtualization solution - base binaries", I've used the Software Center to uninstall the entire package, which also uninstalls "VirtualBox". After that process, any subsequent attempt to install virtualbox-4.3_4.3.6-91406~Ubuntu~precise_i386.deb results in the same error message. And if I search for just virtualbox-guest-additions-iso in the Software Center, it finds it and offers the option to "Re-install" it, but not to remove it.

Why? And how should I proceed?

I'm sure I've done things in my Ubuntu installation that have deviated from the default install. But I've REALLY tried to keep that to a minimum.

  • 1
    sudo apt-get remove packageName is the fastest way to do it. – Alvar Feb 22 '14 at 18:06

There are a couple of ways but first you need to know why there is a conflict. The package that comes with Software Center is maintained by Ubuntu. The one that you downloaded from Virtualbox (The same way I do it) is maintained by, well, VirtualBox (Oracle). Since they have similar packages but different maintained sources, the conflicts of war arise!!

The easiest way to resolve this is to:

  1. Remove all virtualbox packages from the system. To do this I normally use synaptic or aptitude but you can use apt-get also, like this:

    sudo apt-get purge virtualbox*
  2. Install the package from virtualbox.org, which is the virtualbox deb package. In this case the virtualbox-4.3_4.3.6-91406~Ubuntu~precise_i386.deb.

It should work with no problem. If by chance you get an error, install aptitude which is better for looking for several apt problems and then type sudo aptitude search virtualbox. If you find ANY packages that have the i letter in front of them like so:

enter image description here

In this case the virtualbox-4.3 has the i, then purge the package like sudo aptitude purge virtualbox-4.3. This is all to make sure that no conflicts emerge when trying to install the official ones.

Also, just for checking, make sure to download the correct package for your specific arch. If you have Ubuntu 32 Bit, you need to download the i386 package of Virtualbox. If you have the 64 bit, you need to use the AMD64 one.

  • Louis - thanks for the prompt reply, specific enough that even a newbie could love. ;--) But it only worked partially. The apt-get did indeed purge that pesky package. But the subsequent virtualbox install (using Software Center) resulted in this error: Cannot install 'libpython2.7:i386'. GDebi gives the same result. And after installing aptitude, the search yielded no lines beginning with an "i". All p's. Thanks. – scolley Feb 22 '14 at 19:11
  • Which do you happen to have, 32 bit or 64 bit Ubuntu? – Luis Alvarado Feb 22 '14 at 20:26
  • It's 32 bit. Sorry. Should have included that up front. Also, being new here, I believe my original problem has been solved. Exactly as described by Alvar and Luis. So my new problem - the issue with not being able to install Virtualbox due to the new conflict, appears to be off topic for this thread. Thanks for the help! – scolley Feb 23 '14 at 0:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.