OK, After weeks of trying, reading and searching you guys are my last hope. Let me tell you my test environment;

3 different computers;

  1. Desktop with i5 CPU, 8Gb of RAM, Geforce 630 GPU

  2. Notebook with i5 CPU, 4Gb of RAM, Geforce 420M

  3. Notebook with Intel pentium dual core 2Ghz, 4Gb of RAM, Ati Radeon 4700

Notebooks have 750Gb Hard drives, PC has 1TB. Software-wise I follow the exact same pattern for all of them, which is;

Divide hard drive into 4 partitions:

  1. 350 Windows 8.1 startup partition (it creates it itself)

  2. 2000Gb for windows 8.1

  3. 8Gb of Swap area

  4. The rest is Ext4 for "/" of Ubuntu 13.10 64 bit

All systems are installed only the Windows 8.1 64bit, Ubuntu 13.10 64 bit and all updates available (Windows 8.1 also has Norton 360) and nothing else

So no modifications to any systems, neither Ubuntu nor Windows.

However, I can easily click and install both BricsCAD V14 and Draftsight V1R5 and use them without any problems in Windows but when it comes to installing them on Ubuntu 13.10 there is no luck. I have downloaded many 32bit dependencies, tried modifying the .deb files, checking "start them as a program" box.. None helped.

Where I have achieved so far is; they both have their icons on dash. BricsCAD gives me a "activate or try" window and there is no way of passing that screen. Tried "activate trial" in different scenerios and downloading a licence but no luck. Draftsight, on the other hand starts but with only its own drawing. There is no way of opening a new project or another dwg file.. It can save its own dwg project but can not start it after, so no use basicly..

All the computers are exactly in the same situation, nothing I have done was able to give me a ready-to-use BricsCad or DraftSight experience.


There is some tips from this helpful website with helpful people:


  1. install Gdebi from Ubuntu Software Center
  2. sudo apt-get install libcanberra-gtk-module:i386 libcanberra-gtk0:i386 libglu1-mesa:i386
  3. start Gdebi and install downloaded DraftSight package.

It works for me to install Draftsight in Ubuntu 13.10 64 bit environment, for Intel based notebook (i3). I still have problem installing in AMD based system though (A8).

Good luck.


Try to start that CAD software as root user (run as admin in Windows) and see what happens. Maybe there is a problem with user permissions. Maybe you need to add current user account to some group or elevate some (read/write/execute) privileges. If that doesn't work, try that CAD in a liveCD or liveUSB Ubuntu. If it works in live mode, there must must be something wrong with your hard-disk Ubuntu and you should reinstall it (correctly).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.