I recently made Ubuntu 12.0.4 bootable through my flashdrive. I've done this before, and have had no problems on previous flashdrives; the only problem I ran into then was I ran out of space, and now I reformatted my flashdrive to give me more space. The program I am trying to install is Wine 1.7, and the instructions given here aren't working for me this time. When I try and install it through terminal, I get this message every time:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.7 : Depends: wine1.7-amd64 (= 1:1.7.12-0ubuntu1) but it is not going to be installed
           Depends: wine1.7-i386 (= 1:1.7.12-0ubuntu1)
           Recommends: fonts-droid but it is not installable
           Recommends: ttf-mscorefonts-installer but it is not installable
           Recommends: fonts-horai-umefont but it is not installable
           Recommends: winetricks but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

If anyone knows what this means I'd appreciate it.

marked as duplicate by Avinash Raj, jobin, Maythux, Olli, Seth Feb 22 '14 at 19:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Don't think that worked for me. – user233922 Feb 22 '14 at 7:03
  • Are you trying to install wine on Ubuntu live disk? – Avinash Raj Feb 22 '14 at 7:06
  • I'll be honest I have no idea what that means. All I can say is I'm trying to install it on Ubuntu 12.04.3 which is running on my flashdrive. – user233922 Feb 22 '14 at 7:07
  • And try this answer. – Avinash Raj Feb 22 '14 at 7:07
  • why didn't you try to install Ubuntu on your HDD? – Avinash Raj Feb 22 '14 at 7:08

try removing wine repo from sources.list, updates sources.list (sudo apt-get update) And if required add the latest repo info into the list and again update the list.

Try installing wine now.


sudo apt-get check does the trick. You might want to use also apt-get autoclean && apt-get autoremove

Not the answer you're looking for? Browse other questions tagged or ask your own question.