3

(This is on Ubuntu 12.04 LTS with all the latest updates applied.)

One audio application I use a lot is Audacity, both as an audio player and as a recorder, usually with the cheapest headsets I can find.

I also use YouTube a lot (i.e. Flash in Firefox).

The two work together pretty well: e.g. I can play audio from both simultaneously.

Recently, I started to use another audio application: Tartini. Thanks to Jeremy Salwen's and Jevon Longdell's efforts, it compiled without any problems, and after getting OpenGL to work, it runs, too. So I expected it to mix in with the other two:

YouTube, Tartini and Audacity running side by side

but it doesn't. Initially, it wouldn't play any audio at all.

Somehow, I found out that in Ubuntu's "sound settings"

Ubuntu Sound Settings

I had to select 'Digital Output (S/PDIF)' before audio played back with Tartini would be audible - but this mutes YouTube and Audacity. I don't want to need to switch between 'Digital' and non-'Digital' outputs depending on the application I happen to be using. I don't care whether 'outputs' (whatever they are) are 'Digital' (whatever that means); I just want sound produced by an application to play whenever I ask it to, whether or not some other application happens to be playing or recording sound at that time.

Somehow, I found out that there is an application called 'paprefs' that has an option to enable 'simultaneous output on all local sound cards', whatever that means, so I installed it and enabled that option:

paprefs simultaneous output option

This gave me a new option in the Sound Settings:

Ubuntu Sound Settings with new option

and after I selected that, Audacity and Tartini would both play audio, not simultaneously, but whichever was started first. At least, that was the case for a short while; then the previous behavior returned.

After rebooting, the new behavior was restored: I can now play sound from Audacity and/or YouTube, simultaneously if I wish; or from Tartini; but never from Audacity and Tartini, or YouTube and Tartini, at the same time. However, the Ubuntu Sound Settings and pavucontrol are no longer available: pavucontrol claims it can't connect to PulseAudio:

pavucontrol cannot connect to PulseAudio

and indeed, nothing related to pulse is running on my system.

Questions:

  1. What on earth is going on? How do I find out?
  2. Can YouTube and Tartini play sound at the same time?
  3. ... while PulseAudio is running?
  4. How? / Why not?
  5. How does my audio processing hardware come into this?

lspci says I have a 00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)

2
  • 1
    Does Tartini not appear under the Applications tab in sound settings? – dobey Feb 21 '14 at 23:16
  • No, it doesn't. Neither do Firefox or Audacity, by the way. – Reinier Post Feb 21 '14 at 23:25
1

Maybe this won't help you, but I had similar problem - my Tuxguitar didn't make any sound while Youtube was on. I solved it by installing Fluidsynth and Qsynth, then making some random changes in Qsynth (and then Tuxgutar) settings.

I found it (also with instructions) here, on the bottom of the page.

http://ubuntuforums.org/showthread.php?t=2132761

2
  • I doubt this is related - your question seems to be about MIDI playing - but I'll try it anyway, thanks. – Reinier Post Feb 24 '14 at 15:22
  • Well, after installing tuxguitar (which also installs tuxguitar-alsa), it produced the message /dev/sequencer: No such file or directory and remained silent; I fixed that under Tools->Settings->Sound by switching MIDI output to 'Timidity port 0'. If your problem was the same, I don't think it is related to this question. – Reinier Post Mar 1 '14 at 15:41
0

I just found a partial answer by Jan Schmidt here:

It's ten years old and uses an import of the RtAudio audio library that only supports ALSA, which means with a PulseAudio system, it can't access the sound device.

So I suppose the answer is: learn C++ audio programming with RtAudio and upgrade the library yourself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.