This is what i'm working whit.

Ubuntu Server 13.10 /w Kubuntu Desktop
Apache/2.4.6 (Ubuntu)
PHP 5.5.3-1ubuntu2.1 (cli)
Module SuPHP Enabled

My issues:

I can install Joomla, and it looks like its working, but I have to chmod -R 755 on the the root folder of the installation of joomla, in order to get everything to work like its supposed to. (This is not an ideal solution for an server i'm going to use for development of webpages. Anyone have any toughs about were i can start to look, in order to get this issue resolved.

[core:error] [pid 3773] (13)Permission denied: [client] AH00132: file     
permissions deny server access: file permissions deny server access:

in /var/logs/apache2/error.log

afther I install Kuena in joomla.

My solution are to:


chmod -R 755 /home/jostein/www/public_html/administrator/components/com_kunena/

My viritual host conf file

ServerName localhost

ServerAdmin webmaster@example.com
DocumentRoot /var/www/jostein/public_html
  suPHP_Engine on
  #suPHP_UserGroup jostein jostein
        AddType application/x-httpd-suphp .php .php3 .php4 .php5 .phtml
        suPHP_AddHandler application/x-httpd-suphp


Normally the # should't be in front of suPHP_UserGroup but if i remove it i get this error

utput of config test was:
AH00526: Syntax error on line 8 of /etc/apache2/sites-enabled/mysite.conf:
Invalid command 'suPHP_UserGroup', perhaps misspelled or defined by a module not
included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
  • Have you checked this question - How to avoid using sudo when working in /var/www/ – Nitin Venkatesh Feb 21 '14 at 5:11
  • I dont think this issue not related to that issue. I think my issue is that i cant use suPHP_Usergroup in sites-enabled/mysite.conf it gives me an error Invalid command 'suPHP_UserGroup', perhaps misspelled or defined by a module not included in the server configuration. So my php files are exectuted under the default user, instaid of the user that "owns" the vhost. – BD Bear Feb 21 '14 at 6:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.