I am in the process of installing GTK+ but it needs various pre-requisites. These are
- glib - 2.0 >= 2.35.3
- atk - >= 2.7.5
- Pango- >= 1.32.4
- gdk-pixbuf-2.0 >= 2.27.1
Now I upgraded my glib-2.0 to 2.38.2, and I've tried upgrading atk, pango and gdk-pixbuf
checking for GLIB - version >= 2.31.2... 'pkg-config --modversion glib-2.0' returned 2.38.2, but GLIB (2.32.4) was found! If pkg-config was correct, then it is best to remove the old version of GLib. You may also be able to fix the error by modifying your LD_LIBRARY_PATH enviroment variable, or by editing /etc/ld.so.conf. Make sure you have run ldconfig if that is required on your system. If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH to point to the correct configuration files configure: error: GLIB 2.31.2 or better is required. The latest version of GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed but not in the same location as pkg-config add the location of the file glib-2.0.pc to the environment variable PKG_CONFIG_PATH.
I have been go round in circles for the past few hours trying to get this working, if anyone out there can help it would be much appreciated. Thanks in advance