I have received some research that is on 5. 25" floppies. My mobo supports 5. 25" disks, and, I have the disk drive. I am not trying to use this media long term, I just want the research data.


I just found out the file-system is some proprietary system put out by Varian. I have a machine that might be able to read the data... Or that machine might not work. If anyone knows about archaic Varian OSes / File-systems, I would be happy to hear about it.

Image mounting is current priority, I have been able to get disk images using ddrescue, and or safecopy. Both softwares show that there is block errors on some disks. I am still unable to mount the images the disks produce, mount persistently asks for file-system type. Fat, vfat, exfat, fat16 and some others I tried, but they fail, saying something like incorrect FS type. Yes, I have also tried combinations of -o loop.

I have been unable to determine FS type by looking at the hexdump -C output from the image files.

Also, I thried to determine FS type this way:

#dd if=lisa1.iso | file -
/dev/stdin: data 

I still do not know how to get to where I can mount / see files.

I just read that 18k is the standard block-size of a single track, so this is the "native" amount of bits the floppy read heads want to read anyway. It should be fastest and have the best chance of getting all the resalable bits.

I will re-image the disks tomorrow.

My boss says he doesn't know what the File-system type is, or what it might have been. , I may able to locate the instrument which generated the data. This will require time to dig in the graveyard of old science equipment.

I have installed testdisk to try and do data recovery.

I can remember having to do something like this in 2008, but I can't recall now, how I used to recover floppy disk data.

When I run udisk, or mount I get an error saying the floppy is not a valid block device.

$ sudo mount /dev/fd0 Desktop/lisa/
mount: /dev/fd0 is not a valid block device

$ sudo udisks --mount /dev/fd0
Mount failed: Error mounting: mount: /dev/fd0 is not a valid block device


  • Floppy Drive port options are on. I have them set to 5. 25" double density
    • The disk drive models are: Epson SD-700 and Epson SD-600
    • The Disks are Verbatum DataLife MD 2D "Double Density"
    • I have added the module for floppy disks.


$ sudo udisks --mount /dev/fd0
Mount failed: Error mounting: mount: you must specify the filesystem type

Mount gives the same error, but... I Don't know the File System type.

DS QD sect=13 

I ran this program from fdutils. http://www.fdutils.linux.lu/Fdutils.html DS means double sided QD means Quad Density sect=13 is a sector count. I don't really know what the output means, in terms of how to mount the disks and get the data.

What should I do to find the filesystem type?

UPDATE3: As a sanity check, I found a "new" box of blank, formatted floppies, I was able to read and write data, without specifying a File system type.

Assuming the Floppies I have with research on them are formatted, and have errors, might that prevent them from being mounted?

Heres what ddrescue is doing:

$ sudo ddrescue /dev/fd0 ~/Desktop/fd0.iso

Press Ctrl-C to interrupt
rescued:    454656 B,  errsize:   1019 kB,  current rate:        0 B/s
   ipos:    538624 B,   errors:      11,    average rate:       69 B/s
   opos:    538624 B,     time from last successful read:      40 s
  • You apparently used to have to enable the user to have access to floppy disk - answers.launchpad.net/ubuntu/+source/util-linux/+question/… - whether the option is still there I don't know – Wilf Feb 20 '14 at 19:17
  • Do you know which system recorded the data? I remember having HP devices (speaking about '90s here) that used their proprietary filesyistem --- hpfs, hpqfs or something similar. A pain in the back even then, I remember a painful msdos utility that "converted" the files... you can try to search for HPCOPY and HPDIR in this case. Maybe they can run in an emulator... like hp9845.net/9845/projects/hpdir – Rmano Feb 25 '14 at 15:36
  • To (hopefully) determine the fstype, I use: file -Ls . As for HPFS, I saw that on OS/2 disks. Also, there were some tools back in the day that allowed more sectors per track if you used them, then you'd (sometimes) you'd use a TSR "SMAX.COM" that allowed 20 or 21 SPT even on IBM PCs. – The Dude Feb 27 '14 at 5:52
  • I've ran into a couple issues like this, where I was unable to find any documentation about a proprietory FS. Manually lifting the files may be your best bet if you are unable to find any information about the FS. Took me roughly 15-20 hours of work to pull any useful info last I tried it, but it should work as a last resort :p – Thebluefish Mar 7 '14 at 16:41
  • 1
    Some interesting links: google.com/… web.nmsu.edu/~kburke/Instrumentation/VHelper.html. there may be some tools to use these type of disks? See the last section of the PDF "saving data to disk" also mentions a way to use in a Unix console? – Mateo Mar 8 '14 at 1:34

I did some research about Varian files, and I came up with this. Said something about a custom 5 1/4" format for disks, customized BIOS routines - I skimmed it. Sounds like it runs from DOS, so maybe it'll work from DOSBOX? Here you go:
Re-reading it a bit, the last class of computer that they say it reliably works with is a 486 and almost not at all with Windows. If all else fails, at least you have some EXEs you can work backwards from to potentially determine the format. Here's hoping there's not a whole lot of BIOS patching going on. If you need to attack the Pascal EXE, you'll want to UnLzExe/Upack/Uncompress it before you toss it into your decompiler. Program files from that era are almost always compressed in some fashion. Good luck.

Older Updates

Got a lot of tips for you here:

  • Most motherboards these days have the floppy controller turned off, have you verified that it is turned on?
  • Also, turn on the option for a floppy drive seek. If it doesn't seek, you have a problem of some type.
  • Let see, what else... if the connector looks like a Nintendo NES cartridge connector, it is more likely a low density drive (360kiB). If it looks like the old PATA connectors, then it is more likely the 1.2 MiB high density disks. You won't be able to read HD disks in a standard 360k drive.
  • Oh, also, if the light is amber or green the entire time you turn on your computer, the cable is plugged in upside down. Flip that bad boy over, and you'll be good to go.
  • And finally, if this is a Apple / Commodore / Atari branded floppy, you have to have a special card to make it work with an IBM PC. And you will surely NOT be able to read those style disks in an IBM PC drive. Their sectors, clusters and maybe even initial head positions are in different places. I've heard of 3rd party cards that will allow a PC to interface with the drives, but I don't recall what they are.
  • More info is good. Please share what brand/make/model of floppy you are trying to use, and what your motherboard make/model is.
  • Edit: Earned a downvote because the question changed, and I didn't change my answer fast enough. Or it's formatted like crap. Fair enough.

    Updated Answer

    Did you say those had 13 sectors per track? Wonder what kind of disks those are? Research says that they are likely Apple ][ floppies; I don't believe you can read those with a native IBM PC floppy controller. They could also be C64 or Atari disks
    This isn't the one I remember, but it may help you out: http://www.deviceside.com/fc5025.html
    Note: It says it cannot help you read "flippy" disks without an Apple/C64/Atari drives.

    GNU ddrescue

    Oh, I see that you are using ddrescue. Last version I used was 1.14, I can't imagine 1.16 is too different. Remember use -c15 for 5.25 QD, and -c18 for 3.5 HD.

    Quick Rip, not using direct access. Log will help you remember that it is all good:

    sudo ddrescue -Bv -c15 /dev/fd0 floppy.img floppy.img.log

    If the disk has bad spots, skip them. Use log for just hitting bad spots next time

    sudo ddrescue -Bndv -c15 /dev/fd0 badfloppy.img badfloppy.img.log

    If you need to get down and dirty and work around bad sectors, this splits and retries 5 times.

    sudo ddrescue -Bd -c15 -r5 /dev/fd0 bf2.img bf2.img.log

    Mounting images

    That is something I can answer!

    To (hopefully) determine fs type:

    file -Ls floppy.img


    file -Ls /dev/fd0

    Now, once you can mount it loopback.

    mount -t msdos -o loop floppy.img /mnt/floppy

    If it does manage to be one of those pesky HPFS disks, you may be able to use fdisk to determine the offset to mount the hpfs partition, because what you can initially see is just the HPFS FAT-equivalent. I've used it for hard disks before, it shouldn't be that different. Update your question, and I'll return and (hopefully) answer it.

    | improve this answer | |
    • Point 3, I hadn't even thought about, but thats right! both my drives are 360K drives(I think), and my disks are all double density! – j0h Feb 21 '14 at 20:52
    • 1
      Double Sided Double Density (DSDD) disks are 360k disks. the DSHD disks are the high density disks. They were sometimes called Quad Density. DSDD were double from the 180k disks of yore - I guess, I've never actually seen one, I vaguely remember flipping disks in the bad old days of early computers. Post those model numbers to the drives, I'm sure someone will help us track down what kind of drive you have. Oh, and HD/QD drives were compatible with DD disks. – The Dude Feb 21 '14 at 22:14
    • Ill take pictures soon.. and model numbers – j0h Feb 21 '14 at 23:13
    • @j0h Back in the day, Teac made a 5 1/4" and 3 1/2" dual drive in one 5.25" half height package. Let me see if I can find one... Wow, I can't. I've thrown out at least 5 of these things, and more than 30 of those Teac drives. Browsing the auction sites kinda makes me wish I hadn't. Found my drive: az413224.vo.msecnd.net/img/8485/m_8485_21.jpg – The Dude Feb 22 '14 at 5:38
    • I saw some of the prices of these drives. If I never had to recover research again, i would see these! I saw a 5.25 floppy drive sell for ~900$ – j0h Feb 22 '14 at 12:38

    By default, the floppy kernel module is not loaded. To load the module, invoke

    sudo modprobe -v floppy

    Remember to add your user to the "floppy" group; to do that use

    sudo adduser $USER floppy

    After the module is loaded you should be able to access the hardware and mount floppies.

    | improve this answer | |
    • That is an excellent thing to know. I will check it out soon. – j0h Feb 21 '14 at 20:49
    • They don't load floppy by default anymore. Guess that makes sense nowadays. Thanks for the tip! – The Dude Feb 21 '14 at 22:16

    If they're in DOS format, you probably want to use the tools from the mtools package rather than trying to mount it.

    Install the mtools package from the archive, and then use "mdir", "mcopy", etc. to access the files.

    | improve this answer | |
    • Why? You can mount it just fine. – psusi Apr 1 '14 at 22:49

    Your Answer

    By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

    Not the answer you're looking for? Browse other questions tagged or ask your own question.