I have tried almost every comment in this subject. my .xsession-errors file says:

openConnection: connect: No such file or directory
cannot connect to brltty at :0

and that is all. I can login as a guest but not with my account.

  • Checked .Xauthority, the permissions are as it should be. Also deleted .Xauthority and .ICEauthority, did not work. All packages are up-to-date. Please help.. there should be an easy way to restore my desktop. I should not move my files and delete my account. I wait for your comments
    – user250422
    Feb 21, 2014 at 9:26

7 Answers 7


After some days with this issue and many SO threads read, I found that this seems to be an Ubuntu open Bug (Status 'Incomplete' as of July 2015).

More information about it here: https://bugs.launchpad.net/ubuntu/+bug/1285444

The quick solution seems to be to rename the file that stores dconf settings:

$ mv ~/.config/dconf/user{,.old}

Delete both .Xauthority and .ICEauthority from your user's home directory.

If you see old or backup or appended versions of either of these (for example .ICEauthority-c, ICEauthority, or .Xauthority.old) delete those too.

(Not having any of these files will not harm your system. They will be recreated at reboot/login.) After this, just reboot or logout & log back in and enjoy your computer again.

Tested on my system (Xubuntu 14.04 x86, linux kernel 3.13.0-35-generic)

  • removing the .ICEauthority file fixed it for me
    – nedned
    Sep 3, 2016 at 8:23

I also have the same problem, cannot login to ubuntu 14.04, but now I have succeed to login ^_^. This problem also have happened to older Ubuntu version, where I get to know the solution. In my case there was a mismatch on desktop config from the user I login and the available desktop config. Here what i did: ([username] just as a placeholder)

First I check the lightdm.log:

sudo nano /var/log/lightdm/lightdm.log
I had a suspicion on these lines:
    [+27.41s] DEBUG: Session pid=1114: User [username] authorized
    [+27.42s] DEBUG: Session pid=1114: Greeter requests session ubuntu
    [+27.42s] DEBUG: Seat: Failed to find session configuration ubuntu
    [+27.42s] DEBUG: Seat: Can't find session 'ubuntu'

why did lightdm look for "ubuntu" session? This was because of [username] which i use its xsession is ubuntu. It was on /var/lib/AccountsService/users/[username]:

XSession=ubuntu <=====================  THIS ONE


Then i look at the xsession in folder /usr/share/xsessions. There was only gnome.desktop, no ubuntu.desktop.

So that I changed the content of /var/lib/AccountsService/users/[username]:

from XSession=ubuntu to XSession=gnome

Problem solved ^_^

  • 1
    I had to install "ubuntu-session" to be able to login again.
    – Tim
    Apr 12, 2014 at 16:59

I had a similar issue today, I noticed that some files and directories in the users home directory were owned by root, in particular .ICEAuthority, (this was most likely as a result of me trying to setup VNC). Anyway, once I used chown to change the ownership of these files back to the user I was able to login correctly again.


I compiled Krita from source & had to modify the .profile to include the nonstandard install directory. I did it badly apparently. Once I corrected the syntax I could login as expected again!

  • 3
    Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) Dec 5, 2015 at 9:32

I had the same problem on Ubuntu 13.04.

I rewrote the gnome.desktop entry in /usr/share/xsessions because it was missing:

[Desktop Entry]
Comment=This session logs you into GNOME
Exec=gnome-session --session=gnome

Then I removed gnome-session-* and reinstall all. Afterwards everything worked fine and I could choose the session I wanted, unity, gnome and so on.


My problem was solved by turn off auto login.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .