5

After installing Ubuntu, Windows didn't boot so I installed boot repair to fix this problem. But I am getting the message displayed below.

I tried to make a new partition with unformatted file system but still receiving the same message.

How do I fix it?

the screenshot

  • You need to do as the message says and set the bios_grub flag. – psusi Feb 20 '14 at 18:00
2

First you should check if booting the system as MBR/BIOS instead UEFI is really what you intended.

The following is a quote from Is it still possible to install Ubuntu to an external harddrive with UEFI? which is about several ways of setting up bootloaders and necessary partitions. Refer to the original answer if some of the instructions are unclear (it would have been very repetitive to explain almost the same thing in detail 3-4 times).

Creating a BIOS Bootable Partition (BBP) for GRUB is a bit different:

  1. Install the grub-pc-bin package.

  2. Create a partition similar to the instructions above by resizing the root partition and set the bios_grub flag. Choose no filesystem and leave it unformatted.

  3. Edit the configuration file /etc/default/grub with administrative rights and add GRUB_DEVICE=/dev/sdb6 to the end. Replace /dev/sdb6 with the acutal device name of your BBP. You can use the commandline editor nano to keep things simple.

    Install the GRUB MBR image to the BBP with:

    grub-install --boot-directory /mnt/test/boot/ --traget i386-pc $device
    

    You might want to remove or comment out the line in /etc/default/grub and add it to the actual installation.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.