I wanted to run my software on a VPS, however, when I try to run it with mono, it says

The assembly mscorlib.dll was not found or could not be loaded.It should have been installed in the '/usr/local/lib/mono/4.5/mscorlib.dll' directory.

I've already tried to install mono-complete

sudo apt-get install mono-complete

However, it says mono-complete is already the newest version.

Is there anything I can do to fix it?

Sincerely, Mike

( I run on my VPS on ubuntu 13.10 64 bit, and my mono version is 4.0.0)

I came across the problem last day.You need to install mono-2.0 to execute certain programs.

To install mono 2.0 ,open terminal and type

sudo apt-get install libmono2.0-cil
  • Hi, Thanks for your reply, it didn't work though, it's already the newest version – Mike Feb 20 '14 at 15:40
  • @mike version 2.0 is different than 4.0 .They can be both installed at same time.If the command doesn't work, try software center. – Registered User Feb 21 '14 at 9:23
  • I probably explained the it the wrong way, when I executed the command, it says it couldn't install because it was already the latest version – Mike Feb 21 '14 at 11:30
  • try sudo apt-get install libmono-system2.0-cil – Registered User Feb 21 '14 at 11:40
  • Also already the newest version – Mike Feb 21 '14 at 15:40

I had the same problem with my brother's computer. It seems to be an installation problem. MonoDevelop thinks mono's libraries are installed in /usr/local/lib/... I couldn't fix that problem, so I copied /usr/lib/mono to /usr/local/lib

sudo cp -r /usr/lib/mono /usr/local/lib/

That works for now, but that isn't the solution. Anyone knows how to tell MonoDevelop where to look for the libraries? without having to build/install it manually.

  • You could use a symlink instead of copying. – Volker Siegel Oct 19 '14 at 0:01
  • Yes, it's better :) I did that after. And also, I set MONO_PATH correctly. – Nemo Oct 19 '14 at 1:44

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.