I just upgraded our server to Ubuntu 10.04 and cron just stopped working. I tried to restart the server, restart cron but nothing worked for me. It just reports in /var/log/syslog:

May 12 16:32:01 uhor CRON[8424]: Module is unknown
May 12 16:33:01 uhor CRON[8430]: Module is unknown
May 12 16:33:01 uhor CRON[8429]: Module is unknown
May 12 16:34:01 uhor CRON[8432]: Module is unknown

Do you have any idea what's wrong? Some people were reporting also Module is unknown error after upgrading but it was usually with passwd command, not with cron.

This is my /etc/pam.d/cron

# The PAM configuration file for the cron daemon

@include common-auth

# Read environment variables from pam_env's default files, /etc/environment
# and /etc/security/pam_env.conf.
session       required   pam_env.so

# In addition, read system locale information
session       required   pam_env.so envfile=/etc/default/locale

@include common-account
@include common-session-noninteractive
# Sets up user limits, please define limits for cron tasks
# through /etc/security/limits.conf
# session    required   pam_limits.so

I guess there might be something wrong with my pam_* files, but I tried to reinstall them and it didn't help.


This is a bug caused by a security update.

The solution is to restart cron: sudo service cron restart

Do an upgrade, a fix is already available.

| improve this answer | |
  • sudo apt-get upgrade - The fix is already available. – l0b0 Jun 1 '11 at 11:00
  • Too bad that Martin doesn't seem to be coming back to accept; +1 from me. Googling only turned up postings from 2006-2008. – kdgregory Jun 9 '11 at 12:03
  • I ran upgrade today but it didn't help. Still Module is unknown ... – martin Jun 16 '11 at 12:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.