11

Today I was cloning a couple of images of Ubuntu to further expand the use of Ubuntu over the company but just noticed that all cloned PCs have the same Teamviewer ID. I followed teamviewer forum suggestion about purging teamviewer, removing the .config/teamviewer9 folder and even the /opt/teamviewer one with no luck. The ID stays the same even after rebooting or waiting for about 30 mins before installing teamviewer again.

How can I reset/change the Teamviewer ID in Ubuntu for all the cloned computers. Right now I am using the latest version of Teamviewer (Version 9).

6
  • You made sure to stop the Daemon before deleting /opt/teamviewer9/config right? Commented Feb 19, 2014 at 20:05
  • Yes of course. Still the problem was there. Commented Feb 19, 2014 at 20:11
  • @LuisAlvarado have you tried to change mac addresses ?
    – kamil
    Commented Feb 22, 2014 at 9:04
  • @kamil no. Will try tomorrow when I get to work and see if that helps although that would be a very extreme step to take to do something as reset a unique ID for an app like this (Teamviewer missing feature maybe?). Commented Feb 24, 2014 at 1:12
  • @LuisAlvarado any news ?
    – kamil
    Commented Mar 5, 2014 at 12:05

6 Answers 6

8

Close TeamViewer. Then run in the terminal:

sudo teamviewer --daemon stop
sudo rm -f /opt/teamviewer9/config/global.conf
sudo teamviewer --daemon start

Edit: I checked, and TeamViewer also looks at your MAC address. It probably works like this. When you first start TeamViewer (with no configuration files available), it looks up your MAC address. If it is not known by TV, it creates a new TeamViewer ID and associates your MAC address with it. If the MAC address is known, you get the teamviewer ID associated with it.

So, if you clone to a new computer, the commands above would help you get a new ID. If you use them on the original computer, you'll get the same ID.

2
  • I firts it would seem this would fix that problem, even with the variables inside the file, but actually after deleting the whole config file in both, the opt folder and on the .config folder, the problem is the same. I am guessing this should be something the teamviewer team should check out for cases where one wants to clone and have a quick way of solving it. Commented Aug 27, 2014 at 14:31
  • this works for me on Ubuntu 20.04; thank you
    – xinthose
    Commented Oct 19, 2021 at 18:02
3

None of the previous suggestions worked in my case. The quickest and most effective solution I found was to re-install TeamViewer fresh (after uninstall and deletion of config files in Library/Preferences) from an alternative new user account, that solved it immediately.

2

Try to change the MAC Addresses for Cloned PCs

TeamViewer ID depends on it for sure.

2
  • 1
    Verified to work with Teamviewer 9, even without deleting any other configuration files.
    – Rob W
    Commented Sep 5, 2014 at 21:33
  • How do I change MAC Address ? Commented Sep 14, 2015 at 13:20
1

Please close TeamViewer on the new / cloned machine - then run the following commands in the terminal:

defaults delete ~/Library/Preferences/com.teamviewer.teamviewer9.plist
defaults delete ~/Library/Preferences/com.teamviewer.teamviewer9.Machine.plist
sudo defaults delete /Library/Preferences/com.teamviewer.teamviewer9.plist

rm -f ~/Library/Preferences/com.teamviewer.teamviewer9.plist
rm -f ~/Library/Preferences/com.teamviewer.teamviewer9.Machine.plist
sudo rm -f /Library/Preferences/com.teamviewer.teamviewer9.plist
1

A solution is:

Modify /etc/systemd/system/teamviewerd.service:

[Unit]
Description = TeamViewer remote control daemon
After = NetworkManager-wait-online.service network.target network-online.target dbus.service
Wants = NetworkManager-wait-online.service network-online.target
Requires = dbus.service

[Service]
Type = forking
PIDFile = /var/run/teamviewerd.pid
ExecStartPre= /sbin/ifconfig eth0 hw ether aa:bb:cc:dd:ee:ff
ExecStart = /opt/teamviewer/tv_bin/teamviewerd -d
ExecStartPost = /usr/local/sbin/restoremac.sh
Restart = on-abort
StartLimitInterval = 60
StartLimitBurst = 10

[Install]
WantedBy = multi-user.target

Replacing eth0 with your interface and aa:bb:cc:dd:ee:ff with a new MAC.

Create a script cat /usr/local/sbin/restoremac.sh:

#!/bin/sh
/bin/sleep 2
/sbin/ifconfig eth0 hw ether ff:ee:dd:cc:bb:aa

Replacing eth0 with your interface and ff:ee:dd:cc:bb:aa with original MAC.

Use "chmod 755 /usr/local/sbin/restoremac.sh"

Delete /etc/teamviewer/global.conf

Restart machine

You can keep your MAC and change TeamViewr ID.

If you using teamviewer for personal use only, and you have message "Commercial Use Suspected", this solve the problem!

IF YOU USE IT ONLY FOR NOT COMMERCIAL SCOPE!

0

I have found the simplest way to change the ID is to change the MAC address of the NIC. This assumes the cloned machine doesn't require the same MAC address. When the server is restarted

2
  • 1
    This looks like a partial answer... please edit and complete... ;-)
    – Fabby
    Commented Feb 5, 2016 at 23:56
  • Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) Commented Feb 6, 2016 at 2:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .