7

Is there a way to turn NUM LOCK on permanently, across all remote desktop sessions (99% Windows OS) and my local install of Ubuntu 14.04? I have never met anyone in the past 25 years of computing who actually uses a 10-key keypad with NUM LOCK off.

All day I'm hitting the Num Lock key to turn it ON for a particular Remmina (RDP) session. I connect to the same servers most of the day, and my Remmina settings (settings that never actually SAVE!) are to "Remember last view mode for each connection" but I don't think that setting has anything to do with keyboard stuff, just video and interface settings -- WHO'S SETTINGS DON'T SAVE EITHER! MADDENING!!!!!

Thanks!

  • are you connecting to windows or linux? – kamil Feb 19 '14 at 17:48
  • Windows mostly. Can't use XRDP (the only RDP program I've found appealing to me) to RDP to Ubuntu 13.10 anymore. There are only a few Ubuntu 12.04 I connect to, and XRDP works fine for that (after adding the fallback gnome 2d xsession of course). – 00fruX Feb 19 '14 at 17:53
  • your problem is related to only windows machines, try enabling numlock in windows logon startup from registry editor: answers.microsoft.com/en-us/windows/forum/windows_7-hardware/… – kamil Feb 19 '14 at 18:00
  • I just RDP'd using Remmina to an Ubuntu 12.04 server. Opened terminal and tapped some Num Lock keys, nothing. Pressed Num Lock and I could type numbers in the terminal. Logged off, RDP'd back to same server and Num Lock was not on. I don't think it's just Windows. – 00fruX Feb 19 '14 at 18:03
1

The issue with Num Lock key in Remmina can be fixed by installing a newer version from ppa:remmina-ppa-team/remmina-next. This is what I got on Linux Mint 17.1 (based on Ubuntu 14.04 LTS):

$ sudo apt-add-repository ppa:remmina-ppa-team/remmina-next
$ sudo apt-get update
$ sudo apt-get upgrade
$ dpkg -l | grep freerdp
ii  freerdp-x11                        1.2.0~git20141201+dfsg1-0trusty1  amd64  RDP client for Windows Terminal Services
ii  libfreerdp-plugins-standard:amd64  1.2.0~git20141201+dfsg1-0trusty1  amd64  RDP client for Windows Terminal Services (plugins)
ii  libfreerdp1:amd64                  1.2.0~git20141201+dfsg1-0trusty1  amd64  RDP client for Windows Terminal Services (library)
ii  libpam-freerdp                     1.0.1+13.10.20130724-0ubuntu1     amd64  PAM Module to auth against an RDP server using FreeRDP
$ dpkg -l | grep remmina
ii  remmina                            1.1.1-1+547+next~ubuntu14.04.1    amd64  remote desktop client for GNOME desktop environment
ii  remmina-common                     1.1.1-1+547+next~ubuntu14.04.1    all    common files for remmina remote desktop client
ii  remmina-plugin-rdp                 1.1.1-1+547+next~ubuntu14.04.1    amd64  RDP plugin for remmina remote desktop client

It seems this build of remmina uses freerdp-x11.

| improve this answer | |
  • I did this, now Remmina is useless. All my connections now say "protocol plugin rdp is not installed". Hoping a purge/reinstall fixes! – 00fruX Dec 24 '14 at 17:13
  • Ok, got the RDP plugin installed. Now the only "glitch" is Remmina never shows up in the top panel. I have to have the "main window" open all the time. I don't know what's worse. Having to press NUM lock all the time or having to fiddle with just another window open all the time when it doesn't/shouldn't have to be there. – 00fruX Dec 29 '14 at 17:55
1

Yes this is possible, with a workaround. First save this script somewhere

#!/bin/sh
while true
do
sleep 4
numlockx on
done

then type in crontab -e in the terminal, add this entry to it:

@reboot /path/to/script

It should work, restoring numlock all the time.


Source

| improve this answer | |
  • 5
    Are you kidding? a script and a loop ? – kamil Feb 19 '14 at 17:41
  • Well that's what the program equivalents in windows does. – Amith KK Feb 19 '14 at 17:42
  • @AmithKK, not the best with Linux yet. I created a new "empty document" in /home/user/Documents and added your text to it. Then I opened a terminal and typed crontab -e @ reboot /home/user/Documents/NumLockOn but get the following error: crontab: usage error: no arguments permitted after this option – 00fruX Feb 19 '14 at 17:58
  • No, just type crontab -e and press enter, you're supposed to enter the other line in the document that opens. Also, be sure to make the script executable by right clicking>Permissions>Executable – Amith KK Feb 19 '14 at 18:01
  • @dan you should put in your terminal crontab -e then press Enter and paste the script there – kamil Feb 19 '14 at 18:01
0

Virtualbox with seamless mode accomplishes this PERFECTLY. No longer will I have to RDP to a guest VM on my local desktop. Never again will I have to press the Num Lock key. Still baffled why ON isn't the default for Num Lock. Who actually uses the arrow keys on a 10-key keypad!?!?!

| improve this answer | |
0

@rpr, one more line of code and your answer would have worked -- maybe you can edit the answer? Here are the three lines of code that worked for me:

sudo apt-add-repository ppa:remmina-ppa-team/remmina-next

sudo apt-get update

sudo apt-get install remmina remmina-plugin-rdp

| improve this answer | |
  • And not only does it fix the NUM lock issue, the latest version also fixes the bug where you have to press CTRL+T twice to get an image (the remote desktop) to actually show up as explained in another one of my questions: askubuntu.com/questions/454076/… – 00fruX Dec 24 '14 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.