I would like to disable the right click functionality when I click on the right side of the synaptic's touch-pad. I've tried the synaptic tool but it didn't apply the setting.

Below is a question that someone had a similar issue but answers given over there didn't end up solving my issue.

Any help will be highly appreciated.

Thank you.

1 Answer 1


This can be solved using synclient:

Type synclient -l to list your configuration. At the end of the output, you will find something like

RightButtonAreaLeft     = 3068
RightButtonAreaRight    = 0
RightButtonAreaTop      = 4326
RightButtonAreaBottom   = 0

These values have to be changed to 0 (zero) by typing these two commands:

synclient RightButtonAreaLeft=0


synclient RightButtonAreaTop=0

Clicking anywhere on your trackpad will now always trigger a left-click. To right-click, do a two-finger click on your trackpad.

To make these changes permanent, write the two commands to a shell script and add the script to your startup applications:

nano ~/.synaptics-custom-settings.sh

Paste this code to the shell script:

synclient RightButtonAreaLeft=0
synclient RightButtonAreaTop=0

Open the Startup Applications program in Unity and add ~/.synaptics-custom-settings.sh to the list of startup applications.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.