20

I installed Ubuntu 12.4LTS on dual boot with Windows XP on my 7 year old desktop PC 2 months ago. Everything worked perfectly in both Ubuntu and XP until last week when I removed LibreOffice from Ubuntu and installed OpenOffice 4.0.1. (removal/installation done from Terminal as per Ubuntu online instructions).
At the GRUB menu window, the keyboard is now inoperative, so the system times out and boots Ubuntu (which still works perfectly) but I cannot boot XP. The keyboard (USB) works perfectly at the BIOS stage of startup, does not work during GRUB, but works again from the Ubuntu login onwards.
I have looked through the Q&As for a solution, the nearest refers to BIOS keyboard setup, but as my keyboard works in BIOS I don't think this is the cause.
I am not sure where the problem might be. I have looked at grub.cfg, and whilst a newcomer to Linux, cannot see anything obviously corrupt, although I cannot identify which method/module/function call (if any) reads the keyboard. I was considering reloading GRUB, but if the problem is elsewhere this won't solve it, and might make matters worse.
Any advice would be much appreciated.

  • What version of GRUB are you running? Perhaps you could upgrade/reset it in hopes of it fixing whatever GRUB-specific setting that was obviously changed during this process. You should be able to do this from within Ubuntu, or from a bootable USB. – pzkpfw Feb 19 '14 at 8:53
  • Thanks for very quick response. Currently running GRUB 1.99-21ubuntu3.14 (installed 2 months ago). Will wait until this evening, if no other ideas are forthcoming will try reset or upgrade as you suggest. Many thanks. BrianW – BrianW Feb 19 '14 at 9:08
  • Do you know if there's a specific reason you're not running GRUB 2? "GRUB 2 is the default boot loader and manager for Ubuntu since version 9.10" help.ubuntu.com/community/Grub2 I don't think it helps if you're running an outdated boot manager, so I would recommend upgrading unless you have a reason to stay on 1.99 – pzkpfw Feb 19 '14 at 9:24
  • My GRUB 1.99 came with Ubuntu 12.4LTS which I downloaded from the Ubuntu website less than 2 months ago. I assumed it was the latest version, but from your comment is obviously not. I will try upgrading this evening and let you know how I get on. BrianW – BrianW Feb 19 '14 at 12:23
  • 1
    Apparently GRUB 1.98 & 1.99 are both GRUB 2, so I should have latest version. I prepared a boot-repair disk to update or replace GRUB, but now find that my BIOS is no longer booting from CD first (it did when I installed Ubuntu 2 months ago). Today I can't even get into BIOS setup (which I did yesterday & exited without making any changes). PC now boots very quickly to GRUB prompts (skipping all BIOS screens even if Del is held down) then times out to Ubuntu. Something strange going on which I will get to the bottom of eventually, but could take some time. Will post an update when I get there – BrianW Feb 20 '14 at 9:30

14 Answers 14

11

Windows 7 and Ubuntu 14.04LTS dual boot, GRUB2 reinstalled using boot-repair, wireless USB keyboard, no keyboard recognized on GRUB2 screen resolved.

  • BIOS Setup
  • Integrated Peripherals
  • Legacy USB Support --> [Enabled]

I now have up and down arrow keys on the GRUB2 screen. NumLock is now toggled off at boot time, but NBD.

I'm not sure how to mark it RESOLVED, but since it's not a new thread, I don't think I have the power.

| improve this answer | |
  • Oddly, my USB wireless Logitech keyboard start working (but with very slow response) when I choose Legacy USB Support = AUTO, not Disable nor Enable. Asus UX303UB, kernel 4.10, I'm pretty sure it was working before. Default grub setup except for acpi_osi=. – Pablo Bianchi Apr 27 '17 at 2:14
  • Legacy support was it for me. Thanks. – Pixel Jul 16 '19 at 18:03
3

TL;DR. Try all your USB ports including all USB ports on your docking station if you have one.

I just experienced the same thing with a new installation of Ubuntu 14.04.2 LTS and a following dist-upgrade now running the following:

  • Ubuntu 14.04.2 LTS (lsb_release -a)
  • 3.16.0-33-generic (uname -r)
  • grub-install (GRUB) 2.02~beta2-9ubuntu1 (grub-install --version)

The keyboard worked the first times I booted to GRUB so I could boot Windows 8.1 as well but then it suddenly stopped working without any good reason I thought. Just like OP I could use my keyboard in BIOS and USB Legacy keyboard was already enabled so no luck there. Finally I found a PS/2 keyboard which worked in GRUB menu and I could stop the countdown timer. I now tested my USB keyboard in all USB ports on my laptop and in the docking station and it only works with GRUB in one USB port.

Looking back at this of course there was a good explanation. I had moved my desk just after doing my dist-upgrade and had disconnected all cables while doing the move and then reconnected the keyboard to wrong USB port.

I hope this helps.

| improve this answer | |
  • I will plug a new, USB accessory into each USB port when I first get it. I'm told (at least for Windows and its bootloader) each driver install is unique to one, single USB port; it's not a plug-once-then-have-it-apply-to-all USB ports approach--dumb, if that's true, but it is what it is. I'd like to know if each instance of each USB port's driver install uses HD space, or if, following each driver install, logical links are made and substituted, pointing to one, single driver for that version of the driver. I'm not savvy enough to answer that. – The DOuG Trainer Apr 28 '17 at 18:58
2

PROBLEM SOLVED, it was BIOS related (appears BIOS screen is skipped if rebooted with 5min of shut down). Changed boot sequence from Floppy,HDD to CDROM,HDD. Rebooted with NO CD in drive (GRUB not updated),keyboard now works at GRUB screen so can access all options. Now realise that I changed backup coin cell on motherboard around time I installed OpenOffice, suspect this changed boot sequence to default and somehow affected keyboard. Have compared current & previous grub.cfg – identical. Now have boot-repair disk ready for any future issues.

| improve this answer | |
  • Thanks, changing boot sequence to ubuntu solved it for me – Fawwaz Yusran Feb 28 at 2:02
2

In my experience, I had the boot set to "fast" which it would boot up faster, but in doing that, it didn't allow my keyboard to work in dual boot when I would turn on my laptop from shutdown. It would only work right going into ubuntu (obviously when keyboard doesn't work) and/or rebooting which brings back to dual-boot main screen setup. I loaded the default settings which set boot to "normal" and this solved it for me for those that who might be stuck and a last resort before doing a Ubuntu re-install. Hope this helps.

| improve this answer | |
  • how did you load default settings without entering the bios? – ianaz Apr 19 '19 at 13:50
1

Although some time has passed and several hints about not working keyboard in grub can be found on the web, i discovered a reason which to consider may help in some cases:

The USB keyboard may be unusuable in grub because another USB device is also plugged in which interferes with grub keyboard usage.

For details in such a case please see https://savannah.gnu.org/bugs/index.php?57010

| improve this answer | |
1

Turn off the fast boot in the BIOS (it worked for me).

When I hover to fast boot it says something like, fast boot is for minimizing device input for making the load faster or something, so when I turn fast boot off, and save the changes and restart my laptop it works!

| improve this answer | |
0

I also had this problem and it turned out my mouse was somehow prohibiting the keyboard input. I unplugged it and everything worked fine.

| improve this answer | |
0

Mine wouldn't work, In the Award Cmos Setup Utility, I changed first boot device to HDD and the other two disabled, and enabled USB keyboard and mouse, hope this helps.

| improve this answer | |
0

I tried enabling and disabling the BIOS keyboard support, didn't work. (Yes, keyboard works with the BIOS but not GRUB, but does work immediately after GRUB menu using CTRL-ALT-DLT to halt the boot process). While searching I saw someone else said about trying all USB ports. I remembered that the previous week I had moved the keyboard from one USB port to another to make space for a larger USB dongle to be plugged into a nearby USB port. So I moved the keyboard back to the USB port it was in previously and it works. Apparently on this Dell SC440, only some USB ports work with GRUB.

| improve this answer | |
0

Mine was resolved by using a USB2 slot (removing from USB3 slot).

| improve this answer | |
0

My USB-Keyboard Coolermaster Quickfire TK was not responding in Grub2 (or at least making strange inputs like a,e,3 were possible, but on wrong buttons). Another usb- keyboard worked fine.

My solution was to turn the Keyboard itself into 6KRO Mode instead of NKRO Mode by pressing "6" and "ESC".

| improve this answer | |
0

If "fast boot" is causing the problem but you don't want to turn it off, change "USB Support" from "Partial Initial" to "Full Initial" in the BIOS if there is such an option (at least at my GIGABYTE BIOS). This activates all USB devices before OS boot.

| improve this answer | |
-1

I had the same problem but none of the above helped. In my case I had to enable the BIOS option "use USB in DOS".

| improve this answer | |
-1

In my case there was Keyboard and mouse disabled in BIOS. Could look for this in the future.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.