9

I'm configuring an ubuntu server 13.10 box for mailman use. I followed the howto on Ubuntu Help with no luck. Mailman works, running the newlist command creates the list and I'm able to get the welcome email. The web interface does not work.

Accessing to it shows 403 forbidden error.

Apache2 (2.4 version) error log shows:

AH01630: client denied by server configuration: /usr/lib/cgi-bin/mailman/admin

Trying to debug it I saw that with apache 2.4 the Allow from all directive should be changed into Require all granted.

Doing so does not solve the error but change the error as:

AH01797: client denied by server configuration: /usr/lib/cgi-bin/mailman/

I'm stuck here. I cannot figure out where the problem is. For sure is something related to the security execution of cgi, but where?

This is the content of mailman.conf into apache sites:

ScriptAlias /cgi-bin/mailman/ /usr/lib/cgi-bin/mailman/
Alias /pipermail/ /var/lib/mailman/archives/public/
Alias /images/mailman/ /usr/share/images/mailman/

<Directory /usr/lib/cgi-bin/mailman/>
    AllowOverride None
    Options ExecCGI
    AddHandler cgi-script .cgi
    Order allow,deny
    Require all granted
</Directory>
<Directory /var/lib/mailman/archives/public/>
    Options FollowSymlinks
    AllowOverride None
    Order allow,deny
    Require all granted
</Directory>
<Directory /usr/share/images/mailman/>
    AllowOverride None
    Order allow,deny
    Require all granted
</Directory>

thanks.

  • 1
    Please post the complete content of /etc/apache2/sites-enabled/mailman – rechengehirn Feb 18 '14 at 18:37
19

I've found the solution. Apache error is misleading. The problem, simple, is that cgid is not enabled by default and ubuntu HOWTO does not suggest you to enable it.

Simply:

a2enmod cgid

And then, after apache restart, mailman interface will start to work.

  • I'll do...tomorrow...cannot accept immediatly according to stackexchange – Ste Feb 19 '14 at 16:00
  • 1
    THANK YOU for posting this. No other guide or question that I've found mentioned this at all, and it completely fixed my issue! – Savara Nov 3 '15 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.