2

On my laptop, I only have one keyboard layout:
Menu in top panel showing keyboard layout

Now, if I login in to Ubuntu 13.10, and press the # key, I get \.
Similar things occur for other keys - \ become <. UK layout features don't work, as £ becomes #.

But if I open the settings, or select the layout in the top bar of Unity, despite it being the only layout, it does not cause the above problems.

Here is also the window of Keyboard Settings: Keyboard Settings

The layout seems to show correctly (but this is after opening Keyboard Settings, after which it seems alright....): Keyboard layout

I hope to find an answer myself, but I'll see if anyone else has any ideas about this? I haven't had this problem elsewhere... and is a tad irritating when programming.

The laptop in question is Lenovo G570 with Ubuntu 13.10 + Fedora 20 dual boot (I haven't had any problems in Fedora) - Model 4334

  • What keyboard model are you using? 101key, 104key, 105key, etc. – Mitch Feb 18 '14 at 15:07
  • I can't really look it up, it is a built-in laptop keyboard... The keyboard itself looks exactly like this, apart from the UK layout features - £ sign for Shift3 etc – Wilf Feb 18 '14 at 15:14
2

I found the answer in dconf - I changed org.gnome.desktop.input-sources sources from:

[('xkb', 'gb')]

to

[('gb', 'xkb')]

This works very nicely, but seems to have killed the Keyboard Settings:

enter image description here

Probably as I switched iBus and the other thing in a 'incorrect manner' - here is the description of the thing I edited from dconf-editor:

Schema:

org.gnome.desktop.input-sources

Summary:

List of input sources

Description:

List of input source identifiers available. Each source is specified as a tuple of 2 strings. The first string is the type and can be one of 'xkb' or 'ibus'. For 'xkb' sources the second string is 'xkb_layout+xkb_variant' or just 'xkb_layout' if a XKB variant isn't needed. For 'ibus' sources the second string is the IBus engine name. An empty list means that the X server's current XKB layout and variant won't be touched and IBus won't be used.

But as it works still, I'll leave it until it explodes or something.

Update:

Setting it to this also works:

[('ibus', 'gb')]

Weird.

  • +1 for posting the answer to your own question. This doesn't happen enough. Thanks! – Mat Nadrofsky Mar 3 '14 at 19:27
1

I had a similar, very odd issue recently (also in 13.10), where suddenly one day it refused to acknowledge I was using the UK layout (it was trying to force the US one on me, as it seems to be with you - \ instead of #, etc.).

The fix was also slightly odd, but could well sort this out in a similar way. Essentially, go to the Text Entry settings menu as you did already in the question, and add a new layout by clicking the "+" button in the bottom-left (any layout will do - we'll be taking it away later.) Then, remove "English (UK)" from the list by selecting it and clicking the minus button.

Then, re-add "English (UK)" using the same method as before, and remove the dummy layout you added before. In my case, this seemed to remind the computer of the layout it should actually be using, and it has worked fine ever since.

  • Thanks, but it didn't work... I tried it, rebooted, and then tried again and rebooted... Nuthin. – Wilf Feb 18 '14 at 15:42
  • 1
    Hrm. Very odd. In which case I'm out of ideas, I'm afraid. It sounds like something is forcing US layout somewhere, but I don't know what could be doing it (I know all too well how annoying it can be, though - I work on a DE keyboard and have to force UK layout every time, partly to put the symbols in sane places and partly because otherwise I'll swap Y and Z all the time... Muscle memory can be a terrible thing.) – Jez W Feb 18 '14 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.