3

I have just got my new usb wifi dongle and I am trying to get it running on 13.10. lsusb gives me the following:

$ lsusb -v 
Bus 002 Device 005: ID 148f:7601 Ralink Technology, Corp. 
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x148f Ralink Technology, Corp.
  idProduct          0x7601 
...

First thing I have tried was to install the drivers from the cd that was attached to it. There I have found this file 2011_0719_RT3070_RT8070_RT3370_RT5370_RT5372_RT2070_Linux_STA_V2.5.0.3_DPO.bz2 and in the readme there was a note for

ModelName:
===========
RT2870 Wireless Lan Linux Driver

=======================================================================
Driver lName:
===========
rt2870.o/rt2870.ko

After launching sudo make (sudo because I had an issue with copying to cp cannot create regular file /tftpboot' permission denied), sudo make install now I can

$ sudo modprobe rt5370sta

I also have rt2800usb but it also doesn't work.

Now when I enter the usb dongle I get in syslog

Feb 18 15:53:03 xxx kernel: [  302.509247] usb 2-1.3: new high-speed USB device number 5 using ehci-pci
Feb 18 15:53:04 xxx kernel: [  302.969353] usb 2-1.3: New USB device found, idVendor=148f, idProduct=7601
Feb 18 15:53:04 xxx kernel: [  302.969359] usb 2-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Feb 18 15:53:04 xxx mtp-probe: checking bus 2, device 5: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3"
Feb 18 15:53:04 xxx mtp-probe: bus: 2, device: 5 was not an MTP device

I have also tried this http://gowthamgowtham.blogspot.com/2013/11/mediatekralink-wifi-adapter-in.html but when I enter ra0 configuration to /etc/network/interfaces then pc won't boot for more than 1-3 minutes and when it boots there's only lo interface loaded.

EDIT

The best part is that most of the link at MediaTek's website (they had a fusion apparently) is non existent http://www.mediatek.com/_en/07_downloads/01_windows.php?sn=501

EDIT2

After somehow getting my hands on 3.0.0.4 drivers for mt7601U i get the following in syslog

Feb 18 16:55:26 xxx kernel: [ 1975.959906] rtusb init rt2870 --->
Feb 18 16:55:26 xxx kernel: [ 1975.959913] Error: Driver 'rt2870' is already register
ed, aborting...

EDIT3

I somehow got this working but when I launch wpa_supplicant I get the following debug log

http://paste.ubuntu.com/6955249/

1

I believe this error:

Error: Driver 'rt2870' is already registered, aborting...

suggests that either rt5370sta or rt2800usb is already loaded; check:

lsmod | grep -e rt5 -e rt2

Neither is correct for your device. If either is found, unload it:

sudo modprobe -r <driver_you_found>

If either is called in /etc/modules, remove it.

Are there any other interesting clues from any of these?

sudo modprobe mt7601Usta
dmesg | grep -e mt7 -r 2870
iwconfig
| improve this answer | |
  • Thanks for help. I have finally got it somehow to work but I get a problem with wpa_supplicant. Please take a look on a log I attached. – Patryk Feb 18 '14 at 16:48
  • Why are you launching wpa_supplicant manually? Doesn't Network Manager handle all these details as expected? – chili555 Feb 18 '14 at 16:56
  • I am launching this from terminal, on a machine that doesn't have a monitor. – Patryk Feb 18 '14 at 16:57
  • I think you have a new question; how to connect, rather than this question, which driver. Please post one and I'll be glad to help. I suggest you look here: askubuntu.com/questions/421830/… – chili555 Feb 18 '14 at 17:00
  • Ok thanks. I have created a new questions for this purpose : askubuntu.com/questions/422714/… – Patryk Feb 18 '14 at 17:35
6

According lsusb I have the same device:

Bus 002 Device 018: ID 148f:7601 Ralink Technology, Corp. 

The CD contains the following file:

DPO_MT7601U_LinuxSTA_3.0.0.4_20130913.tar.bz2

Can be downloaded from official website, too: http://www.mediatek.com/en/downloads/mt7610u-usb/

Extract the file, enter the directory, which contains the Makefile, and run:

$ make
$ sudo make install

After these steps the device worked seamlessly. Good luck!

In the latest versions of Ubuntu (14.04) a patch is needed. This link explains what is needed: https://unix.stackexchange.com/a/158032/97282

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.