2

For a small automation process I am using xdotool because I need my script to ssh into a virtual machine and execute commands there. After upgrading Ubuntu to 13.10, it seems like xdotool can't type y correctly anymore. Even a simple

xdotool type --clearmodifiers "y"

leads to being typed. It seems to work just fine for characters other than y. I tried un- and reinstalling xdotool, but no success. Any ideas or suggestions on how to fix this?

I have xdotool with version 3.20130505.1 and am using a Dell Latitude E6530 with Ubuntu 13.10.

Edit: Output of gsettings list-recursively org.gnome.desktop.input-sources:

org.gnome.desktop.input-sources current uint32 0
org.gnome.desktop.input-sources per-window false
org.gnome.desktop.input-sources show-all-sources false
org.gnome.desktop.input-sources sources [('xkb', 'de')]
org.gnome.desktop.input-sources xkb-options @as []
  • Works for me. Ubuntu 13.10. Let's see anyone else has same result. – DK Bose Feb 18 '14 at 8:35
  • Have you tried any other desktop than Unity? – user.dz Feb 18 '14 at 10:57
  • @DKBose Which version does your xdotool have? Mine is 3.20130505.1. – Ingo Bürk Feb 18 '14 at 11:10
  • @Sneetsher No, I only tried it on this laptop. Since DK Bose tried it, apparently it's not a "everyone has it" problem. – Ingo Bürk Feb 18 '14 at 11:10
  • 1
    Something I noticed: If I switch to the English (rather than German) keyboard layout, it types both y and z just fine. Maybe this is a layout problem? However, the map Ubuntu shows for the German layout is fine… – Ingo Bürk Feb 18 '14 at 11:48
2

After determining that it's likely an issue with my German keyboard layout, I found this post with the recommendation to run

setxkbmap de

This seems to have fixed the issue for now.

  • Does it work well? As I experienced before setxkbmap doesn't work well with Unity layout switching (in Ubuntu 13.10/14.04). One of them will stop working. – user.dz Feb 18 '14 at 12:55
  • It keeps working if I switch to English, but it stops working when switching back to German until I execute the command again. I caveat I can live with, I don't really ever switch layouts. If there's a better solution I definitely would like to know about it. :) – Ingo Bürk Feb 18 '14 at 14:04
  • May the best thing available is to define layout toggle shortcut using setxkbmap and avoid using Unity ones (shortcuts or indicator). Example: setxkbmap de,us -option grp:alt_shift_toggle . To see all list of possible toggle combination more /usr/share/X11/xkb/rules/xorg.lst | grep grp: . Another point if you want to use right or left ctrl or any key which have two see askubuntu.com/questions/414269/… you may need to modify /usr/share/X11/xkb/symbols/pc . Please, would you update answer after you tested it. – user.dz Feb 18 '14 at 14:23
  • 1
    Since I don't really ever switch layouts this seems unnecessary for me, I just added the setxkbmap command to my automated script. Although it's useful information for people with the same problem. – Ingo Bürk Feb 18 '14 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.