0

I tried chmod and chown, neither worked and I got a message like this, repeated for every file in the drive.

chmod: changing permissions of ‘folder/filename.id’: Read-only file system failed to change mode of ‘folder/filename.id’ from 0644 (rw-r--r--) to 0777 (rwxrwxrwx)

I am trying to gain control of this drive, but it says the owner is "user #99" and the group is "99"

I've looked all over the forum for an answer, but most of the answers direct me to chmod or chown or both, and almost none of these are mac (hfsplus) drives.

2
sudo chmod -R 755 /desired/path
sudo chown -R username /desired/path

Are you using the sudo command? Because you would not have permissions otherwise. This thread looks similar to your issue. In the thread, kidders recommends mounting the filesystem and chown-ing the mounting point:

ls /dev
sudo mkdir /mnt/sdb1
sudo mount /dev/sdb1 /mnt/sdb1
sudo fdisk -l
sudo chown -R username /mnt/sdb1
ll /mnt

The sdb1 is the name of your drive. The fdisk and ll commands are just to show information about what you mounted and its permissions.

This thread says that "Journaled HFS+ currently mounts read only by default on ubuntu." If that's the case, then manually mounting and changing ownership should get you full access.

Edit 1
I created 2 extra partitions (for a total of 3) on an external USB flash drive and had permissions issues. I had to specify the group to take ownership, which may work for you. My username and group are the same:

sudo chown -R username:username /mnt/sdh1
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.