I am trying to install a couple Windows programs, but it fails. I had Wine 1.6, so I thought maybe the latest version had some bugs. So, I uninstalled and re-installed 1.4 from the Ubuntu repo, but the problem persists.

I was trying to Install Meta Trader 4. I am running 12.04 LTS 32 bit version of Ubuntu. I have Wine 1.4 installed.

Please see the screenshot.


Please help me.

  • Please provide more information about the kind of program you were trying to install, what Ubuntu version you have(and whether 32bit/64bit WINE is installed). Feb 17, 2014 at 16:49
  • Just updated the original question. Feb 17, 2014 at 17:07
  • is the program supported in wine DB? check the wine website and search their database to see what rating your version of the program has, if it works at all...
    – Alvar
    Feb 17, 2014 at 17:12
  • Yes, I previously installed MT4. The problem is that I changed brokers to check feed. Now I can't install any program of the platforms. Feb 17, 2014 at 17:52

2 Answers 2


I found the solution. Just gave it a bit of thought, then right clicked the .exe file, went to properties, and Permission, and under Others, changed the permission from READ ONLY to Read and Write. Installed Perfectly.

Thanks all for your help, especially Ashish.

  • Thank you for posting the solution that worked for you, as it might help others in the same or similar problem. :)
    – Alvar
    Feb 19, 2014 at 18:48

I tried out your link and everything seems to be normal. The program is running fine under Wine1.6 (which you already have).

Right Click on the setup and select Open With Wine Windows Program Loader. The setup starts. Uncheck Launch Program after Installation (that might not open it with Wine). Follow all the steps. After proceeding, the file is downloaded and HF MetaTrader 4 is installed (2 successive downloads, progress bar fills twice on mine). Finish the setup and go to dash(Super/Windows key on keyboard) and type "hotforex" and click on HotForex MT4(opens with Wine). This works on Ubuntu. If you face further problems, kindly respond as a comment. [Note:This works for FinFX MetaTrader 4 as well]

  • Alvar: Added the procedure of installation. Feb 17, 2014 at 17:27
  • I uninstalled Wine 1.4 and installed Wine 1.5. But it ended up installing Wine 1.6 as if Wine 1.5 doesn't exist. THis is how I installed - sudo apt-get install wine1.5 Feb 17, 2014 at 17:50
  • Just for info, why are you using only HotForex's MetaTrader? Won't FinFX's work? Feb 17, 2014 at 18:03
  • Because that is where I have opened the account. Feb 17, 2014 at 18:04
  • Can you provide me with a link to the setup? I wish to test it on my PC. Until now, I was testing with FinFX's. Please give a link to HotForex's. Feb 17, 2014 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.