2

I have two subnets with different devices that announce themselves using the Bonjour protocol. Since these messages can be only broadcasted in the same subnetwork I installed the Avahi daemon. I enabled the reflector option and restarted the server but it won't work.

I must note that what I have is a machine running Ubuntu server 12.04 LTS with two interfaces, each connected to one of the two subnets. When the daemon start I can check with 'avahi-browser -ac' that my server is able to see every device in the two subnets, but for some reason the packages are not broadcasted.

Here it follows my config file:

[server]
use-ipv4=yes
use-ipv6=yes
allow-interfaces=p1p1,p3p1
ratelimit-interval-usec=1000000
ratelimit-burst=1000

[wide-area]
enable-wide-area=yes

[publish]

[reflector]
enable-reflector=no

[rlimits]
rlimit-core=0
rlimit-data=4194304
rlimit-fsize=0
rlimit-nofile=768
rlimit-stack=4194304
rlimit-nproc=3

And a small extract from the syslog (which to me seems everything's fine):

Feb 17 16:32:59 shuttle avahi-daemon[2108]: Registering new address record for fe80::82ee:73ff:fe67:e587 on p3p1.*.
Feb 17 16:32:59 shuttle avahi-daemon[2108]: Registering new address record for 192.168.28.27 on p3p1.IPv4.
Feb 17 16:32:59 shuttle avahi-daemon[2108]: Registering new address record for fe80::82ee:73ff:fe67:e546 on p1p1.*.
Feb 17 16:32:59 shuttle avahi-daemon[2108]: Registering new address record for 192.168.38.27 on p1p1.IPv4.
Feb 17 16:32:59 shuttle avahi-daemon[2108]: Registering HINFO record with values 'X86_64'/'LINUX'.
Feb 17 16:33:00 shuttle avahi-daemon[2108]: Server startup complete. Host name is shuttle.local. Local service cookie is 2224955595.
Feb 17 16:33:01 shuttle-bcn avahi-daemon[2108]: Service "shuttle" (/services/udisks.service) successfully established.

I even tried enabling IPv4 forwarding between the interfaces (via /proc/sys/net/ipv4/ip_forward) but I'm not able to see all the devices in the different subnets.

Thanks!

0

I know this is old but in case someone else finds it with the same question...

I believe that you need to change

enable-reflector=no

to

enable-reflector=yes

and restart the avahi-daemon service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.