6

The AMD Catalyst™ 13.12 Proprietary Linux x86 Display Driver can be used with Ubuntu 12.04.2 and 13.04 and the 14.1 Beta version can be used with Ubuntu 12.04.3 and 13.10.

Since, the beta version is known to have a lot of issues, I need to use the stable driver. Unfortunately, it is not working with 13.10 as it said in the documentation.

So, I need to download and install 12.04.2 and disable future updates to 12.04.3 for example.

How I can do this when the version of the Ubuntu that can be downloaded from the official website is 12.04.4 and how can I prevent update to next builds?

4

You can download old Ubuntu versions from http://old-releases.ubuntu.com/releases/12.04.2/

Now choose the version you want (12.04.2) and be sure if you want it 32 or 64bit Then click on it to download.

Now for the updates you can run the update manager from DASH then go to settings and beside check for updates choose never (see the image below)

enter image description here

|improve this answer|||||
  • @wilf Thanks friend i'll edit it but eventhough the first link also give list of old versions including 12.04.2 – Maythux Feb 17 '14 at 11:57
  • Thanks a lot. I have one additional question - is there any definition which updates are making 12.04.2 to be 12.04.3. I am asking to know, should a disable all updates as you have shown, or can forbid particular updates and leave security updates for example? – gotqn Feb 17 '14 at 13:43
  • @gotqn Glad to be able to help you friend.You can keep security updates if you like – Maythux Feb 17 '14 at 13:45
  • 1
    A bit more complicated, but you could also try to keep only the requirements at a certain version: Xserver <=1.14, Kernel <=3.11, Glib <=2.3. This can be done by editing the apt preferences: serverfault.com/questions/435132/… – Requist Feb 17 '14 at 14:30
  • @Requist Thanks. That's what I was asking for, but it's really too advanced for me and required deeper knowledge. Anyway, if you can create such config file for this version I will test it. – gotqn Feb 17 '14 at 20:59
1

In such a case I would pin down the dependencies but let the updates continue. In this manner security issues and high impact bugs in other packages will be dealt with.

In the case of this driver this means: Xserver <=1.14, Kernel <=3.11, Glib <=2.3

The way to do this is described here.

One issue with pinning is that you can not (that I know of) pin down to a version which is not available yet (do not upgrade above 3.5 while current is 3.3). So a direct pinning of this dependencies is not possible.

A way to deal with this is to pin down the current versions and if an update of one of these files occurs check if it still meets dependencies. If so, update the pinning, else leave it pinned.

To pin down to 12.04.2 on these dependencies you install 12.04.2 using the link provided by maythux and make a file /etc/apt/preferences with the following lines:

Package: x-server-common
Pin: version 2:1.11*
Pin-Priority: 550

Package: linux-image-generic*
Pin: version 3.2.*
Pin-Priority: 550

Package: libglib2.0
Pin: version 2.3*
Pin-Priority: 550

But the funny part is that looking at the dependencies I see no reason why the driver should not work with 12.04.4 Then looking at all the distro's they say to support it is obvious they made a list of the distro's on the market in the first half of 2013. So probably it is just a list with tested versions.

If I were you, I would give it a go and install 12.04.4 To be sure it won't break with future updates you put the following lines in the apt preferences file:

Package: x-server-common
Pin: version 2:1.11*
Pin-Priority: 550

Package: linux-image-generic*
Pin: version 3.11.*
Pin-Priority: 550

Package: libglib2.0
Pin: version 2.3*
Pin-Priority: 550
|improve this answer|||||
  • +1 for good explanation and I guess you are right and I should try to use the diver with 12.04.4. I am going to give it a try this week and post the results. – gotqn Feb 20 '14 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.