Whenever I try to run a program from the terminal (apt-get for example) I get a:

apt-get: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /usr/lib/libstdc++.so.6)

Not just with apt-get, but with gimp-2.8, vlc, and other programs. I'll always get the message from before, except with a few simple programs like ls.

Not to mention, I can run gimp, or vlc, or install any program through software center or gdebi through any gui system, be it unity's menu, or nautilus's open with. But when it comes to running these programs through a terminal it never works, and I always get that previous error message.

I mess with my system a lot, so I might have broke something. Also I think I went and modified /etc/sudoers file, and I have been hibernating my computer a lot, does that have any effect?

I'm a newbie in dealing with linux, so I have no idea what caused that problem.


3 Answers 3


You don't have a high enough version of libc6, that is causing the error.

From How to fix “/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found”? – Super User:

That means the program was compiled against glibc version 2.14, and it requires that version to run, but your system has an older version installed. You'll need to either recompile the program against the version of glibc that's on your system, or install a newer version of glibc (the "libc6" package in Debian).

So, you just need to upgrade your libc6 package. All versions of Ubuntu have at least version 2.15 because it's a faily important package (reference).

To upgrade it, use these commands in a terminal:

sudo apt-get update
sudo apt-get install libc6
  • 17
    You cannot since executing apt-get you will get the error... Aug 31, 2016 at 16:14
  • Lol. Sounds like you somehow installed apt-get from a later release of Ubuntu then.
    – sudo
    Jul 24, 2017 at 23:02
  • When you use Python Virtual Environments, this solution does not work!
    – snoba
    Sep 21, 2019 at 10:09
  • Is it possible to get the missing libraries without root privileges? (So no apt-get.)
    – Kvothe
    Nov 20, 2020 at 16:46
  • Not a universal solution. I need to install my network-manager via deb files and have no access to deb. my sudo does not work because it needs GLIBC_2.30 while my version is 2.31 which is higher.
    – ar2015
    Oct 28, 2021 at 7:46

For the benefit of those like me who are only experiencing this issue in one particular directory;

In my case there was a shared library file in my directory that was somehow throwing off the OS. I opened the folder in a file explorer, sorted by 'mime type' then deleted files of the type 'sharedlib' (or application/x-sharedlib) until my command (ls) worked again without that error. In my case the shared library file at fault was named 'libc.so.6'.


I had this issue on Raspbian with RPiCam. It turned out being easier to upgrade my distro than any of the other hacks/workarounds. In my case I upgraded my Raspbian Stretch to Raspbian Buster. I guess the lesson is to always flash the latest Raspbian version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.