LMRoman17 is installed by default in Ubuntu. The font file is lmr17.pfb.

I can use this font in the gimp, but not libreoffice writer. The strange thing is that LMRoman10 (lmr10.pfb) IS available in libreoffice. What's going on?


I have had the same problem with other sizes of the LModern family, e.g. lmroman8. I wanted to use this font for the footnote-style.

The LModern fonts are available to LibreOffice and OpenOffice through /usr/share/fonts/X11/type1.

This directory consists of symbolic links to the font files in /usr/share/texmf, but only for size (in german "entwurfsgröße") 10.

I solved that problem by simply creating a directory /usr/share/fonts/Type1/lm and copying the content of /usr/share/texmf/fonts/type1/public/lm and /usr/share/texmf/fonts/afm/public/lm to that directory. Maybe one could use the opentype fonts in /usr/share/texmf/fonts/opentype/public/lm respectively. This directories contain all faces of the lmodern family.

You need an fc-cache afterwards.

  • I'm pretty amazed by this. I don't know how you solved it, but you did. Can you give me any idea why this problem exists? Is it only with this font, or others too? Thank you kindly for fixing it for me. – Kit Johnson Mar 30 '12 at 2:54
  • I'm glad it worked for you, too. The LMRoman fonts are synchronous available in different font-formats and LibreOffice is more selective than normal X-apps, by only offering the type-version of LMRoman. I think it is an decision made by the package-maintainer of the texmf-lmroman pakage, to link only some of them as type1. Maybe for not perplexing the normal user. – Christian Apr 4 '12 at 14:31
  • Btw: The handling and displaying of the Opentype-fonts (especially with exporting to pdf) is better then with type1. So I can recommend these ones. – Christian Apr 4 '12 at 14:39
  • Thanks very much for explaining this. I think I understand now. This has been really helpful. – Kit Johnson Apr 11 '12 at 2:21

Have you tried rebuilding your font cache? It helps in a lot of cases.

rm ~/.fontconfig
sudo fc-cache -f -v
  • Thanks, I tried that, but it didn't help. Can anyone else reproduce this problem? Like it said, LMRoman17 is a default font, nothing to install. – Kit Johnson May 12 '11 at 8:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.