I have a Ubuntu 12.04 x32 running in a Chroot environment (using Crouton) on my Chromebook. It runs perfectly, and can access the internet. However, it cannot access computers on the local network (it won't discover Minecraft LAN devices, but others can discover and NOT connect to mine), and it won't discover or connect to any LAN devices in Nautilus (error message when opening "Windows Network" saying "Unable to Mount location" and "Failed to retrieve share list from server").

Here is my /etc/hosts file, as default when installed: localhost
::1     localhost ip6-localhost ip6-loopback
fe00::0     ip6-localnet
ff00::0     ip6-mcastprefix
ff02::1     ip6-allnodes
ff02::2     ip6-allrouters

Can someone please help me with this? I need to access samba shares (Raspberry Pi NAS and my desktop computer file shares), and Minecraft LAN would be a bonus :)

  • Can you provide output from : ping <samba host ip> /sbin/iptables -L -nvx /sbin/iptables -t nat -L -nvx
    – dan dan
    Feb 16, 2014 at 19:42
  • Is this all one command? Running it I get "ping: invalid option -- 'x'" Feb 16, 2014 at 20:50
  • dan dan: same output "ping: invalid option x" (does it matter that I'm using xterm?) Feb 16, 2014 at 22:34
  • possible duplicate of why do none of my local servers resolve
    – Braiam
    Mar 3, 2014 at 1:48

2 Answers 2


Google really is your friend tuxgarage has a great guide on your problem and also the command you forgot to get network access is

sudo cp /etc/resolv.conf /mnt/temp/etc/resolv.conf
  • Do I run this inside or outside the chroot? Feb 16, 2014 at 20:45
  • sorry, just saw your comment, before chroot
    – spider623
    Aug 4, 2015 at 10:31

I have found a solution! I didn't see it before because it is for servers, but it worked anyway: https://askubuntu.com/a/146669/48364

It involves editing /etc/nsswitch.conf by moving "dns" before [NOTFOUND=return] instead of after.

I tried it and I can now access my Raspberry Pi NAS!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .