9

I'm on Xubuntu 13.10 64 bit. I've recently had this issue. As a result the sliding bar that is used to control the volume is gone. I can live without it, I can control the volume from my keyboard but I'd like to know if I can install an alternative to the default sliding bar.

I have Xfce4 version 4.10. My volume indicator looks like this, I don't know what it's called, but it's the default one

enter image description here

  • 1
    Looks like the old accept is no longer valid... this is the reason accepts should float after a certain point in time... – Aaron Hall Nov 7 '18 at 15:50
  • @AaronHall What should I accept now? I'm no longer on Xubuntu. Besides this question is for Xubuntu 13.10, which reached its end of life, Newer versions might have a different answer – Lynob Nov 7 '18 at 16:02
  • 1
    I would remove the 13.10 tag, unaccept the current accept, and let the answers float. That would probably help the most people going forward... – Aaron Hall Nov 7 '18 at 16:11
6

It looks like you're not using the default Xfce volume slider (perhaps in Xubuntu it is default, but not in Xfce). I suspect that you're using the indicator plugin, which I don't like nor use. I would suggest that you try adding Audio Mixer plugin to the panel.

To have it available you need to:

sudo apt-get install xfce4-mixer
7

On Xubuntu 16.04 the xfce4-mixer plugin is no longer available.

Try

sudo apt install xfce4-pulseaudio-plugin

(which is not in the goodies package)

1

I used to replace GTK3 indicator (buggy) with the GTK2 one :

  • Open with superuser rights the file /usr/share/dbus-1/services/indicator-sound.service (Mousepad is the default file-editor in Xubuntu, replace it with Gedit or Leafpad if necessary) :

    gksu mousepad /usr/share/dbus-1/services/indicator-sound.service
    
  • Comment the existing line (comment = add a # at the beginning of the line) and add this line under (This will load GTK2 indicator if XFCE is running, and GTK3 one for Gnome/Unity/Others) :

    Exec=/bin/sh -c 'if [ -n "$(ps -U $USER | grep xfce4-panel)" ]; then /usr/lib/indicator-sound-gtk2/indicator-sound-service;else /usr/lib/x86_64-linux-gnu/indicator-sound/indicator-sound-service;fi'
    
  • Your file should look like this in the end :

    [D-BUS Service]
    Name=com.canonical.indicator.sound
    #Exec=/usr/lib/x86_64-linux-gnu/indicator-sound/indicator-sound-service
    Exec=/bin/sh -c 'if [ -n "$(ps -U $USER | grep xfce4-panel)" ]; then /usr/lib/indicator-sound-gtk2/indicator-sound-service;else /usr/lib/x86_64-linux-gnu/indicator-sound/indicator-sound-service;fi'
    

You can also try new indicators by installing xfce4-goodies :

sudo apt-get install xfce4-goodies

Another indicator is, as suggested by landroni, xfce4-mixer :

sudo apt-get install xfce4-mixer
  • there's no file called indicator-sound.service on my entire computer, cause i ran whereis indicator-sound.service and didn't return anything, certainly not in /usr/share/dbus-1/services/indicator-sound.service and sudo apt-get install xfce-goodies unable to find package – Lynob Feb 15 '14 at 22:51
  • My bad, it is xfce4-goodies. And for the indicator-sound.service, you SHOULD have it if you're running Xubuntu 13.10. Maybe you have an Ubuntu + XFCE instead ? – MrVaykadji Feb 15 '14 at 22:54
  • maybe because I disabled the service as indicated in the link above? or not? – Lynob Feb 15 '14 at 22:56
  • the service you disabled is speech-dispatcher, it has nothing (of my knowledge) to do with sound-indicator. – MrVaykadji Feb 15 '14 at 22:58
  • I don't know, i just cant find that file, and about the goodies, I see tons of cool stuff but i see no sound indicator – Lynob Feb 15 '14 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.