I just got done installing Ubuntu 10.04 on an acer laptop. The fan was working fine in Vista but now with Ubuntu the fan doens't turn on, so now it's overheating after an hour or so of use. What's wrong? And if I have to, how do I turn on the fan manually?

P.S. Not my laptop, it's a friend's daughter's.

  1. File a bug. Even if there is a bug that looks like it matches yours exactly, go ahead and file a new, unique bug.

  2. Download the current daily iso. Put it onto a usb drive and boot into the live image to see if that has the same problem.


Of all the people to answer my question, I wouldn't have expected my Dad! He found the solution here: http://ubuntuforums.org/showpost.php?p=4925392&postcount=117

That script is written for exactly the model I'm dealing with, an Acer Aspire 5720z with 2gigs of RAM, though it can be edited for any other model in that line.

Installing that script fixed it. Now the fan runs the way it should.

  • Even if the problem is now solved for you, be sure to still file a bug on Launchpad so that this can be made to work by default in future releases of Ubuntu. – ændrük Sep 20 '10 at 1:14

Don't use it (with Ubuntu) until you find a fix. Constant overheating will eventually kill it dead.

You don't specify the model. Please edit your question to show exactly which model we're talking about.

But I've have seen this problem before around the internet. Everything I've seen suggests that downloading and installing a BIOS update (available from the Acer website) should fix this.


If nothing else works, you might try fancontrol.

Package name is just "fancontrol". Depends on lm-sensors, which is probably already installed on the laptop. Use pwmconfig script to configure it. Use sudo pwmconfig as it needs elevated privileges.

Fancontrol gets and sets settings for fan speed, temperatures at which to start and stop the fans, and so forth.

On my laptop, pwm-config complains the "There are no pwm-capable sensor modules installed"

Running sensors-detect results in "Sorry, no sensors were detected."

Running sensors one temp1 sensor, an ACPI virtual device.

My laptop runs ok, I only mention those errors in case you or others run into the same problems and other answerers have relevant information.

  • 1
    I was having the same problem, and I went off koanhead's info and I removed the fancontrol with the synaptic package manager and rebooted, and now my fan is on always.I know this thread is very old but I posted in case someone else stmbled upon it. Cheers – user139811 Mar 12 '13 at 22:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.