I'm having problem with an external USB hard drive (FAT32). Seems impossible to write, delete etc files, I get error messages saying it is a read only file system. When I try to solve the problem using the chmod or chown commands it hangs, and anyway till the point it hangs it gives many (MANY) messages saying "cannot change.... read-only filesystem"

Needless to say i m the (literal) owner of the drive and i have no idea how this could be considered a read-only drive, never been my intention. And formatting is not an option, the thing is loaded with stuff that's very valuable (for me).

that's what I get when I type the mount command

/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/woodpecker/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=woodpecker)
/dev/sdc1 on /media/musica type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks)
/dev/sdd1 on /media/USB-HDD type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks)

From time to time I get the same problem with flash disks, but then after unmounting and remounting some times I get it solved. Another external USB drive that is almost constantly connected has never had any problem whatsoever...

I understand many people have similar problems but I haven't been able to find any solution that works for me anywhere on the Internet :(

Any tips?



Read only filesystem does not mean the permissions only give you read access ( and fat32 doesn't store permissions ); it means that you either explicitly requested the filesystem be mounted read only, or an error occurred, and so to prevent further damage, the filesystem was automatically made read only. The drive is probably failing. Run dmesg for detailed error messages, and open the disk utility and check the SMART health of the drive.

Most likely you will see IO errors reported in dmesg, and bad sectors in the disk utility.

  • i ll try that thanx!!!!! – user248524 Feb 20 '14 at 15:44
  • i tried this but no errors were found. I ll backup everything somewhere else and format the HDD, i guess... – user248524 Feb 20 '14 at 16:22

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.