1

I installed Lubuntu in a Thinkpad X40 laptop. The OS runs pretty well but it's not detecting (and using) all the RAM installed. The X40 has 512MB of internal RAM memory and an additional module of 1GB. After installing Lubuntu I had been using in the laptop Windows XP for a long period of time and it detected all the RAM (1.5GB) so I assume that the RAM it's not malcfuntioning.

Some data from terminal:

~$ uname -a Linux 3.2.0-58-generic #88-Ubuntu SMP Tue Dec 3 17:40:43 UTC 2013 i686 i686 i386 GNU/Linux

~$ free -m total used free shared buffers cached Mem: 992 895 97 0 25 482 -/+ buffers/cache: 387 605 Swap: 2860 0 2860

~$ grep MemTotal /proc/meminfo MemTotal: 1016400 k

I installed the 32-bit version (actually I installed Lubuntu because the system didn't allow me to install Ubuntu as a result of not being able to run a PAE kernel). As far as I know Lubuntu has a non-pae kernel however it seems that it's not able to detect all the RAM.

I found what it seems to be the solution for the problem but involves recompiling the kernel. I don't know how to recompile a kernel, but I guess I will be able to replace the kernel with another that works.

Anyone knows if there is any non-pae lubuntu kernel capable of detecting more than 1GB RAM? It would be possible to update the kernel to another non-pae kernel that detects the 1.5GB?

Here I found what it seems to be a solution but (as I said, it seems to require recompiling the kernel) [http://archive09.linux.com/feature/119287][1]

3

It isn't the kernel. The bios always reserves some memory for itself, and if you have an integrated gpu, it reserves a chunk of ram for it as well. You may be able to adjust how much it reserves in your bios settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.