7

After I updated ubuntu a new keyboard shortcut appears:

CTRL + SPACE

And I use that shortcut in eclipse to complete commands, and is very practical.

Rather than complete the command appears to me a window to switch the keyboard layout (pt_br Brasil or en_us USA). My keyboard layout uses the Brazilian and I do not want to change.

But I want to know if you have to change this shortcut to not give more conflict with eclipse. Can someone help me?

7
9

Open System Settings and go to "Text Entry" change the keys under "Switch to next source using:" to some other keys.

enter image description here

9
  • Thanks for the tip but it did not. It seems strange, but I did exactly like the picture and the problem persists.
    – Patterson
    Feb 14 '14 at 22:44
  • @Patterson You may need to restart after applying the changes. Did you do that? Also try changing both shortcuts.
    – Seth
    Feb 14 '14 at 22:44
  • So I rebooted! In the settings of this keyboard shortcut set to Ctrl + Alt + Space. but did not change anything when I press Ctrl + Space it still shows the option to change the keyboard layout.
    – Patterson
    Feb 14 '14 at 22:59
  • 1
    Its not Ctrl+Space but Super+Space here and I have the same problem. Changing both hotkeys doesnt fix the problem.
    – BoppreH
    Apr 29 '14 at 18:13
  • 1
    Nice, worked also for xubuntu for me where there is also an ap related to ibus in the taskbar. The app looks like a keyboard with a globe icon or via command line: ibus-setup
    – Karussell
    Aug 28 '14 at 13:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.