7

I've got a Samsung Series 9 notebook (900x3a) running Ubuntu Natty. It's running absolutely smoothly except for some times when the touch pad gets "hiccups" and appears to recognize an additional finger blocking it for normal mouse moves. Toggling the touch pad using the function keys does not help, suspending and resuming it does, tough.

Is there an easier way to reset the synaptics driver than going to standby mode and waking the notebook up again?

13

This worked to reset my touchpad.

sudo rmmod psmouse
sudo modprobe psmouse

If there is no terminal window open, press Alt + F2, type gnome-terminal and press Enter.

Source:
http://xpapad.wordpress.com/2009/09/09/dealing-with-mouse-and-touchpad-freezes-in-linux/

2
  • It works on ASUS X44C Ubuntu 12.04 32 bit after touchpad freezed. Oct 12 '14 at 6:55
  • AWESOME!!! It worked TWICE in "Ubuntu" VERSION="14.10 (Utopic Unicorn)", with KDE, 64 bit in a Lenovo SL410. I don't know WHY the tap gesture sometimes stops working, but these removing and adding the psmouse module, DOES work.
    – David L
    Nov 28 '14 at 15:24
3

Try pressing Fn+F7 or Fn+F8. One of those F keys should control your touchpad. The other is usually sound or video input

2

I think that should be Fn+F5. Not sure if that will help after a freeze though.

Cheers

1

another option it seems is this:

echo -n "reconnect" > /sys/bus/serio/devices/serioX/drvctl
echo -n "reconnect" > /sys/devices/platform/i8042/serioX/drvctl

you can run find /sys -name serio to find available devices.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.