at the moment my laptop does not have any os i am trying to install ubuntu 10.04 but after the initial installation steps it shows an "input/output error during read on /dev/sda" and the installation stops i have no idea what to do? any help would be very useful. thank you

  • What Filesystem/Partition Scheme did you choose during the installation? – aatdark Sep 15 '10 at 16:44
  • i just used the erase and use the entire disk option. – sukrit Sep 15 '10 at 17:32
  • Have your checked your media?. If you hit SHIFT (or ESC, I don't really recall right now and can't test) while booting the installer will show you a menu with more options. There is one to check the install media there. – Javier Rivera Sep 15 '10 at 17:34
  • pressing shift or esc did not have any effect. i even tried the partition, having 60 gb hard disk gave 52 gb to ext4 and rest to swap area, still getting the same error.. – sukrit Sep 15 '10 at 18:27
  • @sukrit Please update your question with all the information you're putting in the comments so that they are all summarized in one place. People leave comments to remind you what they need to help you, so making your question more detailed over time is the best way to do that. – Jorge Castro Sep 16 '10 at 1:59

From your description, it sounds like your disk is dying. To confirm this, I suggest using a low-level disk integrity checking tool, like Salvation HDD Scan and Repair

Formatting the disk will only resolve problems at the filesystem level. If the aforementioned tool detects any errors, your only recourse will be to replace the disk.


replace hard disk......

  • Not so fast, sda could be the installation media. – Javier Rivera Sep 16 '10 at 11:20
  • so wat should i do..?? – sukrit Sep 16 '10 at 13:37

I have experienced this problem because of bad installation media. Download from torrent or check the MD5 sums against the ones here.


sorry,I know this is not a answer,but I can't write a comment

I think that it error because you want to install version that you hardware doesn't support!

[SOLVED] - > After writing

I have this problem,I change the my HDD sata in BIOS. you can read more here .. good luck

  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – fossfreedom Feb 24 '12 at 15:58
  • 1
    +1 just because of the note in italic at the beginning :) – Muhamed Huseinbašić Sep 27 '15 at 13:01

Try some diagnosis on your drive, the Ubuntu-live-cd has a pretty good disc-analysis-tool! Else try SystemRescueCd 1.6.0. These tests will give you an idea if your drive is still ok.

  • i ran the memtest 86 and it said that it was ok and test passed. – sukrit Sep 16 '10 at 13:35
  • Sukrit, just run the Ubuntu10.4 live-cd. Select Try ubuntu. Then System->Preferences->Administration->Diskutility. Is your disc listed up? You can perform some tests here. – Bernard Decock Sep 16 '10 at 16:29
  • diskutility is showin my 60 HD but when i tried using benchmark it showed an error indetails it showed input/output error. i tried formatting,same error.. – sukrit Sep 16 '10 at 17:23

You disk is dying..
Unfortunately, ubuntu can't install correctly on a bad disk...

Not the answer you're looking for? Browse other questions tagged or ask your own question.