16

On my 13 inch screen with 3200x1800px I adapted all fonts to 230 dpi which is ok in most cases.

Also in Settings, I could change Icons of the KDE Theme to 64px.

Only the Icons in the status bar at the bottom right corner (velocity, Network,...) are still only about 16x16 px, which is barely readable. They seem not to obey the same rule.

enter image description here

Where can I change them?

1
  • Perhaps you have a theme installed K > System Settings > Icon Theme that doesn't have the right sized icon for the tray. Maybe if you adjust the height of that panel [Right click and "Unlock Widgets" then drag the Height button] then the bigger icons will fit - I think the tray has extra padding that the launch icons (like Firefox) don't. – pbhj Jun 28 '17 at 23:44
5

The setting to change icon sizes, located in Settings > Appearance > Icons > Advanced, seems to have been unusable for years, as you've noted in your question. This appears to have been the case since some version of KDE 4. Possibly it is related to whether the icon theme is in a resolution-independent format.

A hidden iconSize system tray setting was added around plasma-workspace 5.9. Prior to the addition of this setting, qml files had to be edited.

For a standard plasma panel, open $HOME/.config/plasma-org.kde.plasma.desktop-appletsrc in the text editor of your choice. If you are using Latte Dock, open the $HOME/.config/latte/*.layout.latte that corresponds to the layout you are using.

Look for the entry that corresponds to the system tray. It will look something like this:

[Containments][#]
...
plugin=org.kde.plasma.private.systemtray
...

Then scroll down until you see something that looks like this:

[Containments][#][General]
extraItems=...
knownItems=...
showAllItems=true`

Then add:

iconSize=#

Where # is a number that refers to one of the following options:

0 ~ Small
1 ~ SmallMedium
2 ~ Medium
3 ~ Large
4 ~ Huge
5 ~ Enormous

To see the changes log off and on. Or, in a terminal, kill and restart plasmashell:

killall plasmashell ; sleep 1 ; kshell5 plasmashell

Or latte-dock...

killall latte-dock ; sleep 1 ; kshell5 latte-dock
0
1

It can be adjusted in Settings > Appearance

At the bottom of the window there is a slider for Launcher Icon Size.

Set accordingly

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.