0

I have been trying to improve the power consumption of my Lenovo Z580 running Ubuntu 12.04. Powertop looks like one promising lead and I have been following the instructions provided here: How do I make Powertop changes permanent?

I can unplug my laptop and run sudo powertop --html and I get an html file. Unfortuanately the "software in need of tuning" section does not seem to contain the needed commands for modifying my rc.local file. Rather, it only contains a list of mistuned software.

Note that I have not temporarily set any parameters to "good" under "tunables".

I would like to know if anyone can suggest what might be making the commands that I need not show up in the html file. Thanks!

  • Use laptop-mode-tools OR tlp to optimize, and powertop to check if it is optimised. Powertop is bugged since the introduction of systemd into linux from what I've heard. – MrVaykadji Feb 13 '14 at 0:17
  • Thanks MrVaykadji. I'll use one of those tools instead. – ohnoplus Feb 13 '14 at 17:32
  • In addtion to following MrVaykadji's answer, I'll add that I also was able to markedly improve power management by installing bumblebee as discussed here askmeaboutlinux.com/?p=2360. Z580s seem to run their graphics card at 100% without said modification. – ohnoplus Feb 16 '14 at 4:56
1

powertop is bugged since the introduction of systemd in Linux, from what I've heard. But whatever, the fact is that powertop doesn't work anymore. It is usefull to check your power consumption, but no more to optimize it*.

There are 2 tools designed to optimize laptop's power consumption : tlp or laptop-mode-tools.

=> Even if laptop-mode-tools is present in the official repositories (from Ubuntu), I rather use tlp, because you have less configuration to make :


  • Install TLP from author's PPA : **

    sudo apt-add-repository ppa:linrunner/tlp
    sudo apt-get update 
    sudo apt-get install tlp tlp-rdw 
    
  • Start tlp without restarting (automatically started at boot, unless you uninstall it) :

    sudo tlp start 
    

    Note : the tlp optimization will not work right away, you should plug/unplug your laptop or reboot it in order to notice a difference.

  • Optimizing tlp to manage PCI power-consumption (experimental option, works for me) :

    sudo sed -i 's/RUNTIME_PM_ALL=0/RUNTIME_PM_ALL=1/g' /etc/default/tlp
    
  • Configure TLP further :

    You can read and modify the configuration file (in /etc/default), it is well commented, with :

    gksu gedit /etc/default/tlp
    

    Everytime you change the configuration file, please plug/unplug your laptop, and then run powertop to check the state of your power-consumption. You may also use sudo tlp restart, or restart.


*Note about powertop : it is an old tool and the vm.writeback file is not in the same place it once was, so powertop will always tell you that it is in "BAD" state, even if it is not.

So, by default with tlp, you should have all the states to "GOOD" except this one. But you don't need to do anything, it actually is optimized, powertop just can't see it.

**Note about tlp : if you have a ThinkPad (and ONLY if you have one), you'll also need to run sudo apt-get install tp-smapi-dkms acpi-call-tools

| improve this answer | |
  • Those suggestions seemed to work for my system. After using tlp and switching to RUNTIME_PM_ALL=1 as suggested the only tunables left as bad are the writeback timeout (which Mr Vaykadji says is normal) and autosuspend for the usb device to which my mouse is attached, which I want to leave as bad so I can effectively use my mouse. Thanks for the help! – ohnoplus Feb 13 '14 at 18:22
  • If you are satisfied and want to "close" your question, you can accept my answer (left of my post, small grey "V" checkbox), it will help me gain reputation and thank me for my answer :) – MrVaykadji Feb 13 '14 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.