I am new to Ubuntu Linux. My Professor asked us to download Ubuntu 10.10. I have made several attempts to download MySQL as 32 and 64 bit in Debian packages and it keeps failing. See below for what i wrote in the terminal. As you can see I get an error. I also get an error in the Ubuntu Software Center stating " Dependency is not satisfiable: libatkmm-1.6-1 (>= 2.22.1) ". Could you please give me some guidance so I know what I am doing wrong. Thank you in advance.

root@ubuntu:~# dpkg -i '/home/user/mysql-workbench-gpl-5.2.47-1ubu1204-i386.deb'Selecting previously deselected package mysql-workbench-gpl.
(Reading database ... 118286 files and directories currently installed.)
Unpacking mysql-workbench-gpl (from .../mysql-workbench-gpl-5.2.47-1ubu1204-i386.deb) ...
dpkg: dependency problems prevent configuration of mysql-workbench-gpl:
 mysql-workbench-gpl depends on libatkmm-1.6-1 (>= 2.22.1); however:
  Package libatkmm-1.6-1 is not installed.
 mysql-workbench-gpl depends on libc6 (>= 2.15); however:
  Version of libc6 on system is 2.12.1-0ubuntu6.
 mysql-workbench-gpl depends on libctemplate0; however:
  Package libctemplate0 is not installed.
 mysql-workbench-gpl depends on libglib2.0-0 (>= 2.31.8); however:
  Version of libglib2.0-0 on system is 2.26.0-0ubuntu1.
 mysql-workbench-gpl depends on libglibmm-2.4-1c2a (>= 2.32.0); however:
  Version of libglibmm-2.4-1c2a on system is 2.25.5-0ubuntu1.
 mysql-workbench-gpl depends on libgtk2.0-0 (>= 2.24.0); however:
  Version of libgtk2.0-0 on system is 2.22.0-0ubuntu1.
 mysql-workbench-gpl depends on libgtkmm-2.4-1c2a (>= 1:2.24.0); however:
  Version of libgtkmm-2.4-1c2a on system is 1:2.20.3-1.
 mysql-workbench-gpl depends on libmysqlclient18 (>= 5.5.13-1); however:
  Package libmysqlclient18 is not installed.
 mysql-workbench-gpl depends on libpangomm-1.4-1 (>= 2.27.1); however:
  Version of libpangomm-1.4-1 on system is 2.26.2-1.
 mysql-workbench-gpl depends on libpcre3 (>= 8.10); however:
  Version of libpcre3 on system is 8.02-1.
 mysql-workbench-gpl depends on libpython2.7 (>= 2.7); however:
  Package libpython2.7 is not installed.
 mysql-workbench-gpl depends on libstdc++6 (>= 4.6); however:
  Version of libstdc++6 on system is 4.5.1-7ubuntu2.
 mysql-workbench-gpl depends on libzip2 (>= 0.10); however:
  Package libzip2 is not installed.
 mysql-workbench-gpl depends on python-paramiko; however:
  Package python-paramiko is not installed.
 mysql-workbench-gpl depends on mysql-client; however:
  Package mysql-client is not installed.
 mysql-workbench-gpl depends on python-pysqlite2; however:
  Package python-pysqlite2 is not installed.
dpkg: error processing mysql-workbench-gpl (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for hicolor-icon-theme ...
Processing triggers for shared-mime-info ...
Processing triggers for python-support ...
Errors were encountered while processing:

closed as off-topic by Rinzwind, Thomas Ward, fossfreedom Feb 12 '14 at 19:55

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    10.10? NO he did not... he should know 10.10 is end of life. Use 12.04 and mysql+workbench will install :+ Beside that for future installing: when using DPKG you must manually install all the dependencies. – Rinzwind Feb 12 '14 at 19:26

Open your terminal. Write the following:

sudo apt-get update
sudo apt-get install libctemplate0 libzip1 python-pysqlite2 mysql-client python-crypto python-paramiko
sudo apt-get install mysql-workbench

Press Enter and write down your password then another Enter. Done

  • @Rinzwind I edited the answer – kamil Feb 12 '14 at 19:34
  • When i Open the terminal and type in the command i get this... – user247553 Feb 12 '14 at 19:43
  • user@ubuntu:~$ sudo apt-get install mysql-workbench Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package mysql-workbench user@ubuntu:~$ – user247553 Feb 12 '14 at 19:44
  • @user247553 what do you get? – kamil Feb 12 '14 at 19:45
  • 1
    @kamil That's not what I meant. I meant the dependencies don't exist on the mirrors anymore. 10.10 is EOL which means it is no longer supported. The user needs to use a non-End of Life release. – Thomas Ward Feb 12 '14 at 19:56

You want to install MySQL Workbench.

The version you try to install is made for Ubuntu 12.04 and has some versions requirements for some of the deps.

You need to try with MySQL Workbench for 10.04/10.10 if you are forced to use 10.10, but still it would be recommended to use 12.04.

Also, after you will install MySQL Workbench compatible with 10.10, you will need to do

sudo apt-get install -f

to fix dependencies.

If you downloaded from MySQL.com, then choose older versions (on the right side of Select Platform) and download 10.04 version. Choose 32 if your installation is on 32 or 64 in case of 64.

  • I downloaded Ubuntu Linux 10.04 (x86, 32-bit), DEB and the I get the same error. Is there something else that could be preventing me from installing MySQL? This is what I got when i entered the command you suggested above...is this what is suppose to happen? – user247553 Feb 12 '14 at 19:48
  • user@ubuntu:~$ sudo apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. user@ubuntu:~$ – user247553 Feb 12 '14 at 19:48
  • try to clean any changes previous done. sudo dpkg --purge mysql-workbench-gpl no retry with the recent download and run sudo apt-get install -f to get all those deps. – Gabb3 Feb 12 '14 at 20:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.