5

I have a dual monitor setup with an internal laptop monitor and an external VGA monitor (extended, not mirrored). When I now switch workspaces, this only happens on the internal monitor; windows on the external monitor are always "sticky"!

What I would want is the workspace stretching over both the internal monitor as well as the extended external monitor, and switching workspaces should have the same effect on both monitors.

I do not want to establish separated workspaces on each monitor which are switchable individually. This is a feature for which I found several questions here on the platform, but for my specific problem I was not able to find a solution or even a matching question...

My system is an Ubuntu 13.10 (currently with Gnome Shell) with kernel 3.12. The laptop has an nVidia Optimus graphics adapter; I basically always rely on the precessor's internal graphics adapter.

Thanks in advance!

/edit:

I resolved the issue now. It turned out that it is actually a Gnome problem, this is why I did not find anything with my Ubuntu related search attempts.

You find the solution here: http://gregcor.com/2011/05/07/fix-dual-monitors-in-gnome-3-aka-my-workspaces-are-broken/

The desired behavior is activated by executing

gsettings set org.gnome.shell.overrides workspaces-only-on-primary false

in a shell.

/edit (2017-10-26):

The sketched solution does not work anymore for me in Ubuntu 17.10. A working solution is given in this answer: How can I make gnome-shell treat both monitors in the same way?:

open gnome-tweak-tool and, under "Workspaces", change the "Workspaces only on primary display" setting.

  • You should have answered your own question instead of editing it - this is totally what I was looking for!! – klaffenboeck Apr 26 '17 at 20:24
0

--copied the answer from an edit the OP made to their question --

You find the solution here: http://gregcor.com/2011/05/07/fix-dual-monitors-in-gnome-3-aka-my-workspaces-are-broken/

The desired behavior is activated by executing

gsettings set org.gnome.shell.overrides workspaces-only-on-primary false

in a shell.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.