When I try to gedit some files, then I received these from the terminal window. There is already one post about this: Gtk-WARNING : Calling Inhibit failed

But it is not solved. How can I solve it ? enter image description here


To solve

IBUS-WARNING **: The owner of /home/myPC/.config/ibus/bus is not root!

use gksudo or gksuinstead of sudo to open the file,

gksudo gedit php.ini


gksu gedit php.ini

More on gksudo

The next error

(gedit:12512): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

can be solved by updating gir1.2-gtksource-3.0

sudo apt-get install gir1.2-gtksource-3.0
  • 10
    Lubuntu 14.04 comes with gir1.2-gtksource-3.0 but I still get the "Calling Inhibit failed" warning from Gedit 3.10.4. – August Karlstrom Apr 22 '14 at 12:10
  • same as comment above – jasmines Aug 27 '14 at 13:54
  • "Calling inhibit failed" still happens on 14.04.3 LTS apt-get dist-upgraded on January 2016. The suggested apt-get install gir1.2-gtksource-3.0 is not necessary because the system would already be up to date. – H2ONaCl Jan 2 '16 at 5:44
  • Three comments above still valid under 16.04.2 LTS on July 30, 2017. – WinEunuuchs2Unix Jul 30 '17 at 19:35

There is another way to not deal with such warnings. Use graphical frontend for sudo/su - gksu (in case of gnome) for running GUI programs as root. Gtk-WARNING : Calling Inhibit failed

  • The "calling inhibit failed" warning still happens if you use gksudo gedit which I understand is the same as gksu gedit on some systems. – H2ONaCl Jan 2 '16 at 5:38

When starting an application from the command line, you can avoid verbose output in the terminal after starting the application by using the NOHUP flag before the command and an ampersand following the command.

For example, in this instance you would use:

nohup gedit &


nohup gedit

If you need sudo permission, you should use sudo -i instead of sudo to prevent other problems like so:

nohup sudo -i 

Click here for more info, possible dupe.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.