8

My mobile-broadband USB stick (lsusb: 12d1:1001 Huawei Technologies Co., Ltd. E169/E620/E800 HSDPA Modem) is sometimes detected and sometimes not.

Scenario: I plug-in the stick. It sometimes start to blink and the mobile broadband connection appears in network manager. Sometimes, after the plug-in, a return from suspend mode, or just after a disconnect, it's not starting to blink or just seldomly and the connection does not appear again.

lsusb does not find the device in the latter case. (Not as a normal USB stick, too - I am aware about the mode-switching issue in Linux, but this doesn't seem to be the problem here.)

Sometimes (in most cases) a reboot helps.

Could it be an issue with USB? Maybe something with not providing enough power?

The system: Ubuntu 12.04 on ThinkPad T60

What I tried until now:

  • three different USB ports on the laptop plus using a USB-hub that is powered with an own power source

  • sudo service network-manager restart

  • sudo /etc/init.d/networking restart (is depricated)

  • sudo ifdown -a && sudo ifup -a

  • looking into the mode-switching issue, but since the stick is not listed at all instead of being listed as storage, this seems not to be the issue here)

Update:

tailf /var/log/syslog
Feb 13 09:54:08 laptop NetworkManager[2400]: <info> Unmanaged Device found; state CONNECTED forced. (see http://bugs.launchpad.net/bugs/191889)
Feb 13 09:54:08 laptop NetworkManager[2400]: <info> Unmanaged Device found; state CONNECTED forced. (see http://bugs.launchpad.net/bugs/191889)
Feb 13 09:54:08 laptop NetworkManager[2400]: <info> (wlan0): now managed
Feb 13 09:54:08 laptop NetworkManager[2400]: <info> (wlan0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Feb 13 09:54:08 laptop NetworkManager[2400]: <info> (wlan0): bringing up device.
Feb 13 09:54:08 laptop NetworkManager[2400]: <info> (wlan0): deactivating device (reason 'managed') [2]

Anybody any idea what the network manager is doing there and why?

  • it is blinking ?! - then satellite or modem is blinking too ?! – dschinn1001 Jun 5 '14 at 3:43
5
+25

This is a common problem of Huawei dongles and there is no clearly recognized fix for this. Some Huawei dongles simply switches off when you put your laptop into sleep mode. Here I'm explaining common workarounds you have.

After waking up from sleep, you have to usually remove and plug the 3G dongle back.
In most cases the dongle is re-detected automatically. If not you have to try following commands in your Terminal:

Restart the modem manager:

sudo restart modemmanager

Wait few seconds, until the dongle is prepared, and flip it into modem mode:

sudo eject sr1

(If you don't have an optical disc drive, change sr1 to sr0)


You can clearly identify whether the dongle is detected or not by reading the Linux kernel ring buffer. Execute this command in Terminal and plug in your dongle:

watch 'dmesg | tail -f'

A sample output:

enter image description here

In the above image my Huawei dongle has been successfully detected. You have to check whether your dongle gets detected like this after waking up from sleep.


It is known that some Huawei hardware doen't work properly without the proprietary driver.

You can install Huawei Mobile Partner software (which includes the driver) and try to establish Internet through it:

enter image description here

There is a higher chance that you can find the Huawei Mobile Partner available inside your dongle.

If you don't have the driver with you, heres how to download and install it:

Installing Huawei Mobile Partner 22

  • If you don't have Internet to the host machine, first click here & download the Huawei Mobile Partner 22 to your Home directory. Then execute the below command in Terminal:

    tar -xvzf megafone.tar.gz; cd mp22-linux-64; chmod +x install; sudo ./install

  • If you already have Internet to your machine copy the below command into the Terminal at once and execute it:

    wget -O mp22-linux-64.tar.gz https://db.tt/XtrP9KPw; tar -xvzf mp22-linux-64.tar.gz; cd mp22-linux-64; chmod +x install; sudo ./install

If your dongle is not detected by 22nd version of mobile partner, you may try installing 21 or 23.

Alternatively, you can use Sakis3G to connect your dongle to the Internet.

| improve this answer | |
  • 1
    I had the same problem in Ubuntu 14.04. Mobile Partner 23 fixed the problem. Now I am using Mobile Partner instead of Network Manager. Thanks a lot. – Gobinath Feb 22 '16 at 14:55
  • @Naveen all the links are down regarding installing mobile partner 22 please provide working links as I am too suffering from it – Kasun Siyambalapitiya Sep 16 '16 at 12:45
0
  1. Plug-out USB-stick (if stick plugged-in)
  2. Run sudo service network-manager stop and wait to stop (network-applet will be gone)
  3. Plug-In USB-stick
  4. Wait 20-30 seconds
  5. Run sudo service network-manager start (network-applet will be back)
  6. Now mobile-broadband will be detect at network-applet (with stable detection) within 20-30 seconds. Then connect to Internet via your mobile-broadband.

I am using following script on my Ubuntu-14.04 PC with (HUWEI) Idea-Netsetter. so-that I can easily connect my mobile-broadband and get stable connection every time (say at this time I also connected by this method!)

#!/bin/bash
    zenity --info --text="Plug Out"
    sleep 5
    sudo service network-manager stop
    zenity --info --text="Plug In"
    sleep 30
    sudo service network-manager start
    zenity --info --text="Connecction will be available within 30 seconds"
    exit
| improve this answer | |
0

I also had the same issue and it was intermittent , it used to connect sometimes although. After lot of hit n try i found it . Just plug ur dongle , if it does not connect , reboot it without REMOVING dongle. Bingo !!! it worked on my system .

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.