I've spend a couple of hours now trying to get my wifi card working. I moved the PCI-card from a working machine to a new one. Both running Ubuntu 12.04. The card worked fine in the first machine but now it cannot find any wireless networks. I'm using wl driver as it was told to be working with BCM4321 chipset. And I used this page as a guide for installing: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx#A12.04_.28Precise_Pangolin.29_-12.10.28Quantal_Quetzal.29

I hope somebody can give an advice to help my misery :) Details below.

dmesg (BCM4329 looks suspicious as the chipset should be BCM4321):

root@mymachine:/# dmesg | grep -e wl -e eth1
[    1.425064] wl: module license 'MIXED/Proprietary' taints kernel.
[    1.429110] wl: module verification failed: signature and/or required key missing - tainting kernel
[    1.479959] INFO @wl_cfg80211_attach : Registered CFG80211 phy
[    1.526081] eth1: Broadcom BCM4329 802.11 Hybrid Wireless Controller (r326264)
[  988.710494] INFO @wl_cfg80211_attach : Registered CFG80211 phy
[  988.737879] eth1: Broadcom BCM4329 802.11 Hybrid Wireless Controller (r326264)
[ 2083.164833] ERROR @wl_dev_intvar_get : error (-1)
[ 2083.164840] ERROR @wl_cfg80211_get_tx_power : error (-1)


root@mymachine:/# lspci -vvnn | grep 14e4 04:05.0 Network controller
[0280]: Broadcom Corporation BCM4321 802.11b/g/n [14e4:4329] (rev 01)


root@mymachine:/# iwconfig
eth0      no wireless extensions.

eth1      IEEE 802.11abg  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=200 dBm
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

lo        no wireless extensions.

virbr0    no wireless extensions.

lshw (Is driver=wl0 OK?):

root@mymachine:/# lshw -C network
       description: Wireless interface
       product: BCM4321 802.11b/g/n
       vendor: Broadcom Corporation
       physical id: 5
       bus info: pci@0000:04:05.0
       logical name: eth1
       version: 01
       serial: 00:21:29:6d:7b:98
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion= (r326264) latency=32 multicast=yes wireless=IEEE 802.11abg
       resources: irq:21 memory:fdafc000-fdafffff

lsmod (The driver doesn't really communicate with the kernel right?):

root@mymachine:/# lsmod | grep wl
wl                   3074978  0
cfg80211              499466  1 wl
lib80211               14381  2 wl,lib80211_crypt_tkip

The changes I made to /etc/modprobe.d/blacklist.conf (added the 3 last ones):

# replaced by b43 and ssb.
blacklist bcm43xx
blacklist brcmsmac
blacklist bcma
blacklist b43

iwlist scanning:

root@mymachine:/# iwlist eth1 scanning
eth1      No scan results

You have 3 possible solutions

  • Use Ethernet (connect a cable to the router and to your PC) then go to settings manager -> additional drivers and look for where it says use Broacom driver (something like that)
  • If you didn't find that driver. Then do this solution sudo nano /etc/modprobe.d/blacklist.conf and then add blacklist b43 and remove brcmsmac from being blacklisted. then go to sudo nano /etc/modules and add wl or brcmsmac. The latter works on my PC. I have broadcom too but not the same one.
  • If none of these solutions work, then upgrade to Ubuntu 13.10, connect to Internet using Ethernet and then go to additional drivers and you will find a Broadcom driver for sure.


  • Thanks fo an answer. I actually forgot to mention that I have the Broadcom STA wireless driver activated and in use (shows up in the Additional drivers list as well.) I also have an ethernet cable plugged and I'm using the computer over SSH. – quinz Feb 11 '14 at 18:44
  • @quinz did you restart the computer after that you activated the driver? – Lynob Feb 11 '14 at 18:45
  • yes, I've booted it several times since I've tried different things (mostly enabling and disabling different drivers). – quinz Feb 11 '14 at 18:46
  • after activating the driver, did you do sudo apt-get upgrade? that happened to me, the driver wasn't working well before i did that – Lynob Feb 11 '14 at 18:48
  • Now that's weird. I did as you said and nothing was upgraded. Yet right after "iwlist eth1 scanning" gave several hits :) Let me check if this will work after the reboot as well. – quinz Feb 11 '14 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.