1

I tried to install Ubuntu 12.04.4 LTS on my new notebook but the installation failed saying stopping mount network filesystem.

So I tried with Linux Mint 13 mate 64bit, and the installation succeeded, even if neither ethernet nor wireless connection was working during install.

After installing everything is fine except that I neither have ethernet nor wireless connection at all. The network manager reports No network devices detected.

Specifications:

  • Acer Aspire E-522- 65204G1TMnkk

  • Processor is a 4x AMD A6-5200 APU

  • Radeon (TM) HD Graphics, 4gb RAM.

The output of lspci -nn:

01:00.0 Ethernet Controller (0200): Atheros Communications Inc. Device (1969:10a1] (rev 13)
05:00.0 Network Controller (0280]: Atheros Communications Inc. Device (168c:0036] (rev 01)

Any suggestion to fix this problem?

Here I am with the results of the commands: - ifconfig:
lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:28 errors:0 dropped:0 overruns:0 frame:0 TX packets:28 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:1920 (1.9 KB) TX bytes:1920 (1.9 KB)

  • sudo dhclient eth0: Cannot find device "eth0"

Update 12 february:

I found the solution, both for the ethernet card and the wireless adapter, but the problem is that they do not work together. Doing:

"Download compat-drivers source code https://www.kernel.org/pub/linux/kernel/projects/backports/2013/03/04/compat-drivers-2013-03-04-u.tar.bz2

Extract the tarball and type the following commands on a terminal:

cd [path-to-extracted-driver] ./scripts/driver-select alx make sudo make install Reboot the system"

the ethernet connection worked well. But still no wireless.

After that, I followed these suggestions for the wireless adapter:

"sudo apt-get install linux-headers-generic build-essential wget http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v3.6/compat-wireless-3.6.6-1-snpc.tar.bz2
tar xvf compat*
cd compat-wireless-3.6.6-1-snpc
sudo su
./scripts/driver-select ath9k
make
make install
modprobe ath9k
exit"

Even if the last command "modprobe ath9k" didn't work, I rebooted and I had the wireless working BUT .... no more ethernet again!!!

Is there anybody who can tell me how to solve this?

  • What is the output of the "ifconfig" command? What if you run "sudo dhclient eth0"? – bluszcz Feb 11 '14 at 11:40
  • here I am with the results of the commands you suggested: ifconfig lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:28 errors:0 dropped:0 overruns:0 frame:0 TX packets:28 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:1920 (1.9 KB) TX bytes:1920 (1.9 KB) sudo dhclient eth0 Cannot find device "eth0" – user247006 Feb 11 '14 at 13:54
0

It seems that you are owner a device with chip ath9k: http://wireless.kernel.org/en/users/Drivers/ath9k

There are several ways to handle the problem, for example turning off a hardware encryption:

http://www.emmolution.org/?p=253

  • Ok thanks: I went to emmolution.org/?p=253 and followed instructions: sudo nano /etc/modprobe.d/ath9k.conf adding options ath9k nohwcrypt=1 but I now have a terminal open with this line added in it and I cant understand how to save and exit... – user247006 Feb 11 '14 at 14:30
  • I tryed the solution of turning off hardware encription but it did'nt work at all. No change in wireless. And I also have problem with ethernet. The network manager still reports: NO NETWORK DEVICES AVAILABLE.. – user247006 Feb 11 '14 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.