11

The function SHOW DESKTOP when moving mouse to the HOT CORNERS in ubuntu 13.04 worked.

After updating to 13.10, SHOW DESKTOP/HOT CORNERS only works until rebooting or setsid unity, after which it doesn't work.

I thought that something was wrong in the update to 13.10, so I made a clean install of ubuntu 14.04 to find out that the same issue exists.

What can I do to make SHOW DESKTOP/HOT CORNERS work again?

I have already tried to reset compiz and unity, and I did fresh install.

  • For future visitors to this page: The fixes proposed below apparently cause another bug. Also worth noting that Ubuntu's default keyboard shortcut for "Show desktop" is Control-Super-D (super is the usually the "Windows" key next to Alt) – user606179 Feb 2 '18 at 1:19
12

I was able to solve the problem by brute force.

Moving every single option in CompizConfig Settings Manager I did find that when Unity was disabled then Show Desktop works as expected with the HOT CORNERS.

So i click every single checkmark in Ubuntu Unity Plugin to finally find that Show Live Previews of Windows in the Switcher was the one to blame. (After unchecking it hot corners works as expected.

5

A temporary solution until the bug has been fixed, could be to use xdotool.

  1. install:

    sudo apt-get install xdotool
    
  2. in compiz config manager, under General Settings, insert a command line

    xdotool key super+d
    
  3. in edge bindings, configure the hot corner

Works for me. Ubuntu 14.04

  • Also, after having reinstalled 14.04, I decided to run with Nouveau instead of nVidia drivers and it seems less buggy now, although it could be other factors as well. I had a lot of graphics-related bugs and black screens before, which are now gone. (I have a laptop with nVidia 650M card) – user8437812 May 17 '14 at 9:32
  • this only made my keyboard type the letter 'd' when going to the assigned corner. – Kalamalka Kid Jan 18 '16 at 8:06
  • @KalamalkaKid, Check your Compiz settings: Open CompizConfig > Ubuntu Unity Plugin > General; there is a setting called "Show Desktop" which should be mapped to "<Super>d" – user8437812 Feb 13 '17 at 16:59
  • This solution works on Ubuntu 16.04.2 LTS. – Vesnog Feb 14 '17 at 21:43
4
  1. Open CompizConfig Settings Manager
  2. Under CATEGORY choose Desktop
  3. You will see "Ubuntu Unity Plugin"
  4. On the rightmost tab called "Switcher" uncheck SHOW LIVE PREVIEWS OF WINDOWS IN THE SWITCHER as Ivanyosan suggests above
  • this didtn work in 14.04 – Kalamalka Kid Jan 18 '16 at 8:09
  • This worked in Ubuntu 14.04.5 64-bit as of now. – Vesnog Jan 12 '17 at 19:38
3

Ubuntu 14.04 is currently still in development - it will not be available properly until April 2014. You don't need to upgrade to it yet :-).

Anyway, using unity-tweak-tool, set this...

enter image description here ..and you should be able to show & hide the desktop by placing the mouse in the lower-right corner - it works very nicely in 13.10.

  • 2
    yeah, it is supposed to work like that, but in my case it doesnt. show wall and show windows work but show desktop doesnt. It's very strange. – Ivanyosan Feb 11 '14 at 0:25
  • 1
    Actually... Most of the time it seems to work, but half the time it doesn't... All the others also work perfectly all the time... – Wilf Feb 11 '14 at 0:31
  • 9
    i wonder why it works the first time only. (in my case) – Ivanyosan Feb 11 '14 at 0:36
  • 2
    Even for me. Show desktop works only for first time! Any updates? – Vishal Vyas Apr 23 '14 at 10:39
  • Currently, this functionality doesn't work with Unity Tweak Tool in ubuntu 14.04. It has been reported as a bug. – Richard Povinelli Apr 27 '14 at 21:03
1

Unfortunately these fixes work on some computers and not on others. I personally haven't found any change when unticking the Compiz Untiy Plugin under "Switcher" tab. It doesn't seem to make a difference. So the problem still remains on one of my older desktop computers that no method above would work. So I tried a different approach and it seems to work on every computer and is very consistent. Here is what I did. First make a bash script. To do this create a "New Document" from your right click menu and choose "Empty Document". In this new document paste this:

#!/bin/sh
sleep 3
compiz --replace

Now save this file as "compiz-start". Make sure to set its permissions to "Allow executing file as program" ticked and move this file to /usr/bin/. You may also want to change to ownership to ROOT if you haven't already.

Now create a .desktop file to trigger this script. First right click and choose "New Document" then "Empty Document". Open this file and paste the follow text into it:

[Desktop Entry]
Type=Application
Exec=compiz-start
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name[en_US]=compiz-trigger-start.desktop
Name=compiz on start
Comment[en_US]=compiz on startup
Comment=compiz on startup

Save this file. It should save automatically as "compiz-trigger-start.desktop". Move this .desktop file to either your home autostart folder ~/.config/autostart (which will only work for the user) or place it into /etc/xdg/autostart which should make this fix work for all users of the system (or future new users).
This has worked for me on all computers that it was tested on...even the one that previously nothing had worked. You can tell that it works because just after the Desktop loads and the Unity bar shows up; the screen will reload itself...which is Compiz restarting. The "sleep 3" is critical to this working. I hope that help you guys fix this "hot corners", "Show Desktop", "Spread Windows". Chris

  • to avoid breaking Yakuake, I had to do this: metacity --replace sleep 3 compiz --replace – Aquarius Power Mar 5 '15 at 19:28
  • this second part doesn't make sense to me. How is it connected to the first script in anyway? Why wound't we just add compiz in the startmenu programs instead of creating a .deskto file? Also, the command 'compiz-start' is not recognized in Ubuntu 14.04 =) – Kalamalka Kid Jan 18 '16 at 8:27
0

To make "Toggle Desktop" work for example with unity-tweak-tool here the solution:

Uncheck "Show live previews of windows in the Switcher" under the tab "Switcher" of the Ubuntu Unity Plugin

You'll find the Ubuntu Unity Plugin under the CompizConfig Setting Manager. Type ccsm in the Terminal.

Found the solution here.

0

I did uncheck SHOW LIVE PREVIEWS OF WINDOWS IN THE SWITCHER as Ivanyosan said. But it still doesn't work for me. After unchecking the whole Ubuntu unity plugin and then check it again, CCSM will show a lot of warring that other plugins have same function as the Ubuntu unity plugin does. Then choose to use Ubuntu unity plugin instead of other plugins. That works for me on ubuntu 1404.

  • Please restructure your post to help answer the OP in clear terms. – George Udosen Dec 30 '16 at 4:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.