9

This question already has an answer here:

each time I open Ubuntu I have to turnoff bluetooth function from the top panel. my questions is that is there any method to make it disabled by default?

marked as duplicate by Pilot6, Eric Carvalho, Charles Green, Mark Kirby, Ravan Dec 23 '15 at 2:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

10

To disable bluetooth service on startup

sudo nano /etc/rc.local

add this line before exit 0

rfkill block bluetooth
  • Unfortunately I don't know what to do after adding the last code, In other words how can I save changes? – Muhammed Feb 13 '14 at 10:35
  • Press ctrl+x and ctrl+s to save your change. This script is running each time you turn on the computer. So this line will turn off the bluetooth – jhilmer Feb 14 '14 at 15:58
  • To save is actually Ctrl+O (the letter, not zero) – Nathan J. Brauer Aug 21 '14 at 22:13
  • You can also use gedit to do this, if you are not comfortable with nano :) – user3459110 Nov 27 '14 at 8:58
  • This doesn't work on Thinkpad X250 + UbuntuStudio 16.04 LTS – amirteymuri Aug 7 '16 at 9:50
-1

Following the answer here, what worked for me (in Ubuntu 14.04) was

sudo gedit /etc/bluetooth/main.conf
InitiallyPowered = true     # keep it that way
# add the following:
# start bluetooth on boot?
# compatibility note: if this variable is _not_ found bluetooth will start
BLUETOOTH_ENABLED=0

Save the file and reboot.

  • This didn't work for me – Grzegorz Chrupała Jul 2 '16 at 13:34
  • Didn't work for me on Ubuntu MATE 16.04 – Prahlad Yeri Aug 4 '16 at 6:39
  • This doesn't work on Thinkpad X250 + UbuntuStudio 16.04 LTS – amirteymuri Aug 7 '16 at 9:53
  • You shouldn't downvote it. I just posted what worked FOR ME in the hope it could be useful to someone. – Rodrigo Apr 22 '17 at 22:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.