4

Whenever I try to set the performance mode of my Nvidia 525M gpu from adaptive to performance, it actually works, but only until I reboot my PC. After a reboot/relog I have to do it all over again via nvidia-settings.

  • What is the official/safest way to make that change permanent?
  • Why doesn't nvidia-settings save the performance mode it has been set to? Is it a bug?

I am using the official Nvidia 331 drivers provided by Ubuntu 12.04.4 64-bit LTS.

Thanks!

5
  • Does the info in the link also work for Ubuntu 12.04.4 64-bit? The user in the link is using Ubuntu 12.10. I just want to be sure before I change something so important, especially if it requires editing/hacking xorg.conf etc. – Aquablue Feb 10 '14 at 16:46
  • Yes, it works for any Linux distro that uses a Proprietary Nvidia driver. It's not a big deal, and you'll probably need to create xorg.conf, cause it's not there by default. – mikewhatever Feb 10 '14 at 16:49
  • Hello Mike, thanks for the answer. Are you 100% sure of this? I ask because I have seen reports about it causing boot issues etc. According to another user, the code is different for each gpu. See here: askubuntu.com/questions/172806/… – Aquablue Feb 10 '14 at 16:51
  • Well, I've tested mine, and know that it worked, ...for me. I haven't seen reports of boot problems, anyway, in case you have any, the change is easily reversible. – mikewhatever Feb 10 '14 at 17:12
  • Hello friend, thx for the help you gave me. I decided to ask Nvidia directly about this, just to be sure. Below is the official answer/workaround for this issue. – Aquablue Feb 11 '14 at 9:09
8

Solution for my GPU question: I contacted Nvidia directly via live-chat, because I wanted to know how to fix the issue above in the most safest and easy way. There are a lot of old guides on the net. Some work, some don't work. I need the risk to be minimal, since I am on a stable LTS machine here.

This is the workaround Nvidia provided me for Ubuntu 12.04.4 LTS 64-bit:

It is expected that powermizer settings are not saved after reboot.

As a workaround, you can set "prefer maximum performance" on the command line with nvidia-settings -a [gpu:0]/GpuPowerMizerMode=1. Replace gpu:0 with gpu:N if there is more than one GPU.

You can place that nvidia-settings invocation in ~/.xinitrc or some other startup script. (It must be done after X is started)

I recommend doing it via the "start-up programs" utility, because it's relatively easy and because it ships with Ubuntu 12.04 LTS. Copy and paste the command into it, save and it will load on the next restart.

Screenshots

1. Open the start-up program utility and add the recommended command and a comment into it: First step

2. Activate it afterwards: Second step

3. Restart your computer and check PowerMizer via nvidia-settings: Third step

Done. Maximum power! Btw, this also helps if Unity is running slow or if you have any form stuttering, tearing, slowdown or lag in apps when PowerMizer switched from a low to a high performance-level. Credit goes to Mike from Nvidia customer care. He responded to me within 24 hours after asking my question, which is great. I am posting this information to let other Ubuntu users know how the issue was fixed. Thanks!

Update for Maxwell GTX 900-series GPUs: See This spreadsheet. It details setting up overclocking. Search for Nvidia to get the necessary details. This was tested on a GTX 970 on Kubuntu 14.10.

1
  • it works perfectly.this eliminates randomn lags in desktop effects in linux mint 18.1.it should also help in gaming.but i only recommend this for desktop.downside is high power consumption and heat.thank you aquablue. – john9983 Jan 13 '17 at 12:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.