1

What is the problem in that? I work in xubuntu x86_x64 I get the following error while trying to execute install_bin :

mohamed@mohamed:~/Desktop/installer_v3.0$ ls 
batch_installer  install_bin  installer  install.now  setup.sh 
mohamed@mohamed:~/Desktop/installer_v3.0$ ls -l
total 44
-rw-rw-rw-  1 mohamed mohamed 8533 Jan 24  2013 batch_installer 
drwxrwxrwx 13 mohamed mohamed 4096 Feb  9 19:29 install_bin
-rw-rw-rw-  1 mohamed mohamed 9179 Jan 24  2013 installer
-rwxrwxrwx  1 mohamed mohamed 9179 Jan 24  2013 install.now
-rwxrwxrwx  1 mohamed mohamed  497 Jan 24  2013 setup.sh     
mohamed@mohamed:~/Desktop/installer_v3.0$ ./setup.sh  
/home/mohamed/Desktop/installer_v3.0/installer: Permission denied. 
mohamed@mohamed:~/Desktop/installer_v3.0$
1

The error message is pretty clear at what the error is:

/home/mohamed/Desktop/installer_v3.0/installer: Permission denied.

It's trying to execute the file named installer, but installer doesn't have the execute bit set, as can be seen in the ls -l output.

-rw-rw-rw-  1 mohamed mohamed 9179 Jan 24  2013 installer

so

chmod 755 installer

and try again.

  • 1
    This is actually the right answer. The different filename was intentional as it's the installer file with permission issues, not the setup file. ( @hmayag ) – kiri Feb 10 '14 at 10:18
  • 1
    @minerz029 but my first answer did the work and solves the problem: sudo sh setup.sh – kamil Feb 10 '14 at 10:32
  • 1
    @minerz029 And what bothers me is the way my answer was downvoted immediately before geirha put his answer although my answer was right enough to solve the problem – kamil Feb 10 '14 at 10:34
  • 3
    @kamil, downvote was from me, for jumping straight to sudo. sudo isn't the answer to everything. – geirha Feb 10 '14 at 10:46
  • 1
    @geirha Ok I got the point. +1 for comment and answer. I respect your patience. please edit your answer so I can remove the downvote – kamil Feb 10 '14 at 10:47
1

I found that you're new to askubuntu. so I will start by jumping to sudo command.

try

sudo sh setup.sh

It should work because your script setup.sh is using installer also

sudo should work but you can do it the other way (correct way - as the other answer by @geirha):

sudo chmod +x installer

and then run your setup.sh as you were trying

./setup.sh
  • I tried this but see – user246638 Feb 10 '14 at 14:01
  • not work it still say Permission denied. – user246638 Feb 10 '14 at 14:02
  • after I use sudo -i it say WARNING: The Installer must not be run from a root user account. Instead, Installer must be run from a regular user account. Installing tools from a root account is not supported; in certain cases this may cause a tool to fail to run properly for some or all users To run installer as root (not recommended), please re-invoke installer with the -install_as_root switch. – user246638 Feb 10 '14 at 14:02
  • @user246638 try sudo sh setup.sh -install_as_root Or try the second solution which is safer – kamil Feb 11 '14 at 14:00
  • @user246638 have you tried the answer? – kamil Feb 13 '14 at 11:35
-1

Have you tried this:

sudo bash
sudo su
sudo sh /.setup.sh
~/desktop/installer3.0$ ls

and then it might work fine this way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.