1

I have setup Ubuntu 12.0.4 Server 32-bit on a home PC and am trying to simply share a basic file directory on that server for read-write access from a Ubuntu 12.0.4 64-bit client (via NFS and Samba - and only reason I'm trying both is that I can't get NFS to work, so tried Samba, and both are giving me the same results 'Permission denied').

In both instances from the client (NFS and Samba) I can successfully connect to the fileshare, but both NFS and Samba 'tell me' I can't write to it 'permission denied'. I've tried to avoid the server side chmod 777 route and give anyone god access to destroy all of my server files in one click, so I'm looking for (what I'm hoping is) a more sophisticated and appropriate approach to do this.

  • Hi! You will get more attention if you stop writing stories and just mention the error (not the situation). Otherwise, it would be hard to get any response. I recommend to you to edit this and be more specific. – Lucio Feb 16 '14 at 3:36
  • Thanks, Lucio. I was trying to provide all info I could to help clarify. I can look to cut it down. – khans52 Feb 17 '14 at 5:26
  • Cut down description to simplify problem statement per Lucio's suggestion. – khans52 Feb 23 '14 at 18:48
2

Issue was with file directory ownership. 'root' was the owner of file directory. I used chown to change directory ownership to user and usergroup that I am sharing files with and read/write then worked from all laptops.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.