I've had my Thinkpad T420 (integrated graphics, 8GB RAM, i5) for less than a month. I couldn't successfully install Natty (installer finished, but wouldn't boot), so I went with Maverick instead. On a daily basis, it completely freezes at least once, seemingly always when I'm in Firefox with multiple tabs open. My mouse can still move, but nothing is clickable, and I always have to do a hard restart.

I confirmed that this isn't a Unity bug, because I installed 10.10 in "command-line only" mode via the alternate install dvd, and manually installed X-server and fluxbox. The freezing still exists, without Unity or even Gnome running, whenever I do anything mildly resource-hungry in Firefox.

Thanks for any guidance.

  • Does it depend on whether you are browsing flash content or not?
    – htorque
    May 10 '11 at 18:10
  • No, I do not have Flash installed.
    – oskar
    May 10 '11 at 18:12
  • According to Phoronix Sandy Bridge support is broken on 11.04: phoronix.com/… I'd recommed using vesa drivers until 11.10 Jun 24 '11 at 11:04
  • You can also get the newest intel drivers from git and compile them yourself. This seems to work phoronix.com/… Jun 24 '11 at 11:06

I have had my T420 for just over a week and am experiencing multiple problems with it. I initially installed Ubuntu 11.04 32bit which installed fine, but would crash several times each day. So I switched to the classic interface, but still was experiencing the type of anomaly that you describe; the mouse pointer moves, but the interface is completely unresponsive to mouse clicks.

I then decided to install 11.04 64bit since I will be upgrading the RAM soon. This install also went fine and soon had my system up and running. Unity still crashed frequently, so I switched to classic mode. However, this time I chose classic mode without effects. I have not experienced any crashing or locking up in the three days since I made this change.

I would recommend that you try installing Natty again, but try running it in classic mode without effects until some of these bugs get worked out. I also recommend adding information to the bugs that have been already filed on Launchpad and also open new bug reports for problems that have not already been reported.

  • I appreciate the input. I tried installing Natty twice but both times it boots to a black screen and stays that way. I'm using the alternate disc with LVM encryption (not optional for me). I really hope these bugs get fixed soon; it was a pretty big expense for me. Too late to return. Anyway thanks again.
    – oskar
    May 11 '11 at 2:25

I had the same or at least a similar issue with natty 64bit installed on a thinkpad L520 (sandy bridge, too). It didn't boot and showed only flickering green lines. Well, I found a solution by looking at the Grub2 documentation on a German Ubuntu site. There I stumbled over the following sentence: "if there are boot problems with the default grub2 settings (black or distorted screen), then you should choose the following setting. With this setting a list of problematic graphic cards ("blacklist") is processed during boot." (rough translation) So I added the following line in /etc/default/grub (open the file with sudo or gksudo):


saved it and ran:

sudo update-grub

Now booting just runs fine.

Best wishes, absurd

  • Do you know a way to run that in the installer? I haven't been able to get past that step, so I have no grub to update...
    – Stephen RC
    Jul 6 '11 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.