I just do update and upgrade, but I miss close, minimize and maximize button along with top border title bar after that.

I did metacity --replace and unity --reset, It didn't work for me.

Also, I set in the gconf-editor default metacity>general to close, minimize, maximize:

and it didn't work.

The last, I unchecked windows decoration in Compiz, and it didn't work too.

Any help will be highly appreciated, and I attach a screenshot of a window without the title bar as one example of my problem.

enter image description here


Hope this works: try this:

gtk-window-decorator --replace
|improve this answer|||||
  • I tried it before, it doesn't work at this time. – bagustris Feb 10 '14 at 13:58
  • I updated to 14.04, and the problem still presents, missing title bar on some window application such as terminal, skype and other. – bagustris Feb 12 '14 at 14:06
  • why did you update to an unstable version. it has to be buggy. I researched about your system drivers but Intel stopped driver support of 12.04. try this link 01.org/linuxgraphics/downloads. try to install a stable version like 13.10, the drivers are available. My system with NVIDIA has these types of problem initially. but when new version of updated drivers came, it got resolved. – kushvarma Feb 12 '14 at 14:11
  • However, it is solved after upgrading to 14.04 and do update - upgrade continuously. – bagustris Feb 13 '14 at 7:06

This problem prevails only when the video driver of the system is not compatible or not installed. Check in hardware upgrade, is there any updates available for your hardware. And if not, search for the drivers for the specific hardware and install it to overcome this problem.

|improve this answer|||||
  • Thank's for your reply. I think so. However, it back again after I uninstalled intel-graphic-driver, doing again metacity --replace, unity --reset and check compiz window decoration. Thank you! Love the Ubuntu and the community! – bagustris Feb 9 '14 at 7:02
  • which system do you have? and does it has external graphics card like nvidia or AMD? – kushvarma Feb 9 '14 at 7:12
  • I use Ubuntu 12.04 precise. Sadly, the problem appears again, I don't have title bar on some of my apps window. My machine is lenovo g580 i7, i think it uses intel graphic card. no external graphics is used. – bagustris Feb 10 '14 at 13:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.