I use Xubuntu 13.10 and have installed the Intel Graphics Installer. I did it in order to reduce the amount of screen tearing with the VESA drivers earlier. But I see "tear free" as disabled, when I do:

cat /var/log/Xorg.0.log

I can see tear free is disabled. I'm putting in the line:

[  1718.525] (**) intel(0): "Tear free" disabled

How do I enable tear-free? I have the 945GM graphics driver. Any kind of help is appreciated.

3 Answers 3


TearFree is disabled by default. To enable it create the directory,

sudo mkdir /etc/X11/xorg.conf.d/

Then add to the file /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod" "sna"
   Option      "TearFree" "true"

I have run into this problem with xubuntu 16.04.2. Tear free stopped working. In my case, for some reason the package xserver-xorg-video-intel was no longer installed. Xorg.0.log said the intel module was not loaded, and that instead the modesetting driver was loaded, and as great as that may be, the config file to set tear free was being ignored. Restoring the package fixed things, tear free worked again. I don't know if this is how it is supposed to be: the xserver-xorg-video-intelpackage description says its use on post 2007 hardware is discouraged, but horrible tearing graphics is much more discouraging.

The package in my case is actually xserver-xorg-video-intel-hwe-16.04


The solution presented by bain worked for me, but only after removing the /etc/X11/xorg.conf file. A rename backs it up additionally, in case you want to restore it at some point.

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.back

In my case, the file was automatically created by the nvidia driver and not needed by my system. It's unknown to me, why & what interfered with the intel device settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.