1

My old Canon printer has just died and I've replaced it with a Canon MG5550 inkjet printer. I run Ubuntu 12.04 LTS. I have downloaded drivers into my Download file but am stuck. What do I do next?

Sorry but I am one of the new breed of ignorant non-techie Linux users who has escaped from Windows so I need a step by step guide. So is there anyone who can spell out the commands for what I do next please?

I have the following files now in my downloads folder but what do I do next please?

/home/john/Downloads/scangearmp-mg5500series-2.20-1-deb.tar.gz
/home/john/Downloads/cnijfilter-mg5500series-4.00-1-deb.tar.gz

I unpacked these by right clicking on them.

Next I double clicked on the right deb file hoping to install it my system Update Manager gave the following error message:

Dependency is not satisfiable....
  • I have now (after several hours!) got it working. I gave up sticking with v12.04 and upgraded my Ubuntu to v13.10. The above downloads would not install. However after trial and error I installed the accompanying file: cnijfilter-common_4.00-1_i386.deb and with that installed it allowed me to install the MG5500series drivers. Even then I had problems (another couple of hours) getting the printer to actually work! I must admit my patience early snapped and I almost went out and bought a Mac - it's only because I believe in and support the open source movement that I didn't. JohnR – user246193 Feb 10 '14 at 11:46
  • It could be very helpful to tell us where you downloaded the scangearmp-mg5500series-2.20-1-deb.tar.gz and cnijfilter-mg5500series-4.00-1-deb.tar.gz files. Thanks – user254561 Mar 4 '14 at 7:54
  • 1
    @user254561: to download the files corresponding to your printer, go to Canon web site of your country (I saw downloads on US, Australia and France websites), type the reference of your printer, on the printer page follow link to "support and downloads", there select as OS "Linux" and your language, then you have your links to download. – Stéphane Gourichon Jan 18 '15 at 18:38
0

Download the latest debian packages for your printer from here.

There's a package that supports the scanner, and an "IJ" package that supports the printer.

You can open and extract them with Archive manager.

The content of the scangear package looks like this:

scangear5500

Run the highlighted install.sh script to install the scanner requirements.

The content of the IJ package looks very similar, and again, run the install.sh script to install the printer requirements.

If you have difficulty with the install scripts you can try installing the deb packages directly which will be found in the packages folder. To do this choose the packages that correspond to your version (i386 for 32-bit or amd64 for 64 bit and double click them to install with the software center. If you have difficulty installing the deb packages with this approach and get errors regarding dependencies, take a look at this.

Note: I do not have one of these printers to test this solution with but if something is unclear or you get stuck feel free to drop a comment and we will do our best to help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.